How To Keep Tool Dialog Box Open

3075
9
Jump to solution
12-12-2013 07:17 AM
JonathanMulder
New Contributor III
Yesterday, I checked a checkbox that would automatically close the dialog box for a geoprocessing tool.

But now I want to keep the dialog box open so I can look at the results and Python code.  Any tool I run now just automatically closes the dialog box.

QUESTION: How can I reset my preferences so that the dialog box remains open?

Thanks,
Jon Mulder
0 Kudos
1 Solution

Accepted Solutions
DanLee
by Esri Regular Contributor
Esri Regular Contributor
I see, you meant the checkbox on tool processing dialog:  Close this dialog when completed successfully. Once you checked it, it stays that way until you have a chance to uncheck it. If your process is very fast you may not have time to do that. Try a process that may run longer than 5 seconds (e.g use a larger dataset). When it's running, uncheck that box (on the left side just above the processing message area).

Hope that helps.  🙂

View solution in original post

0 Kudos
9 Replies
DanLee
by Esri Regular Contributor
Esri Regular Contributor
By default, the Background Processing is enabled. You can go to Geoprocessing - Geoprocessing options... - uncheck the Enable box under Background Geoprocessing. The tool dialog should stay now.

Does that work?
0 Kudos
JonathanMulder
New Contributor III
Thanks, but that doesn't work.  I've checked and unchecked the "Background Processing" checkbox.  Although I can't replicate the step I took, I think it was that when the tool finished processing in Foreground, the dialog box shows the messages printed out during the process, and a button in the upper right said something like "Close the Dialog box".  Also, somewhere on the dialog box, there was a checkbox (I think) that said "Always close dialog box when tool is finished".  That is the checkbox that I enabled and the dialog box ALWAYS closes now.

I guess an ultimate solution is to uninstall ArcMap and re-install so that all the defaults are back to normal...

Jon Mulder
0 Kudos
DanLee
by Esri Regular Contributor
Esri Regular Contributor
I see, you meant the checkbox on tool processing dialog:  Close this dialog when completed successfully. Once you checked it, it stays that way until you have a chance to uncheck it. If your process is very fast you may not have time to do that. Try a process that may run longer than 5 seconds (e.g use a larger dataset). When it's running, uncheck that box (on the left side just above the processing message area).

Hope that helps.  🙂

View solution in original post

0 Kudos
JenniferKennedy
New Contributor II

Is this still applicable in the software today?  Run a longer process so you have time to uncheck that box?

0 Kudos
DanLee
by Esri Regular Contributor
Esri Regular Contributor

Yes, I have confirmed that it's still the way in ArcMap and probably won't change unless there is a strong request. Sorry about the inconvenience.

JenniferKennedy
New Contributor II

Okay, thanks for the confirmation!  

0 Kudos
JonathanMulder
New Contributor III
Dan,

I ran a long script and I was able to uncheck the checkbox.  Thanks!

Jon Mulder
0 Kudos
DanLee
by Esri Regular Contributor
Esri Regular Contributor
Glad to hear that. You are welcome!
0 Kudos
JenniferKennedy
New Contributor II

Is this still true?  Is the only way to reset this setting to run a tool that takes a longer time to process, so you have time to uncheck that box on the running tool?

0 Kudos