Hotspot (Getis Ord Gi*) and ISA script Error:"<type 'exceptions.AttributeError'>:..."

625
2
09-20-2012 07:25 AM
PeterKohler2
New Contributor III
[ATTACH=CONFIG]17847[/ATTACH][ATTACH=CONFIG]17848[/ATTACH][ATTACH=CONFIG]17849[/ATTACH][ATTACH=CONFIG]17850[/ATTACH]Hi,

I'm using ArcGIS 10 (service pack 4) and getting the error below whilst using the Hotspot (Getis-Ord Gi*) tool and the downloadable Incremental Autocorrelation Script (ISA):

<type 'exceptions.AttributeError'>: DescribeData: Get attribute extent does not exist
Failed to execute.


ISA Script Iâ??m using available from here http://www.arcgis.com/home/item.html?id=694e0f97355740d7bba6b8b356c0b925

Aware there are number of threads reporting problems with ISA tool, and with similar error, and that it is available as part of 10.1.

In my case, both scripts are in their own geoprocessing models, with inputs supplied via a Copy, Integrate and Collect Events setup. See screenshots.

I managed to get around this the error briefly with the ISA model by defining the study areaâ??s Extent in the Environmental Settings (named "Extent", see attached). I could then run the model in the model window only, using the dialogue would set off the error. However, this was only temporary, I then setup the hotspot model as shown and got the same error â?? irrespective of which â??viewâ?? I tried to run it in Model or Dialogue in. Returning to try the ISA model again, it also stopped working in both â??viewsâ?? and I havenâ??t been able to get either working now.

Can anyone advise?

Best Regards

Peter
0 Kudos
2 Replies
by Anonymous User
Not applicable
Original User: janikas

This is a bug that has been traced to a missing "extent" when using CreateFeatureClass... which CollectEvents among other tools use to create output.  We are working towards resolving in a future SP... but for the time being you can:

1. Run CopyFeatures
2. Run AddSpatialIndex

to the CollectEvents result in order to properly set the extent describe property.  In short, the problem lies not with Gi* or ISA or any other tool down the line... they are simply calling the same code on initialize... one of those tasks is to describe the input... the problem lies upstream in CollectEvents.  I apologize for the inconvenience.  Please let me know if these rather annoying added steps resolves the issue for you.  TY,

MJ
0 Kudos
MarkJanikas
New Contributor III
As a follow up... I am being informed that this bug has been fixed in SP5... and I am positive that it does not persist in 10.1.  As such, please try to lay down SP5 and see if it fixes the problem.

MJ
0 Kudos