Geoprocessing Service Result Map Service Labels

931
3
11-28-2012 11:40 AM
SamDrummond1
New Contributor
Hello,

I�??m working on a geoprocessing service that returns a layer as an output. This layer is going to be rendered in the ArcGIS Viewer for Silverlight (3.0.1) and needs to be symbolized with graduated colors and needs to be labeled with values from one of the attribute fields (frequency).

I have successfully published this geoprocessing service and have been consuming it in the viewer. The results are returning correctly symbolized but I�??m have not been able to successfully return the labels. According to the documentation in the link below; when the result of a geoprocessing service is returned as map service, �??The symbology, labeling, transparency and all other properties of the return map are the same as the output layer in the current ArcMap session.

http://resources.arcgis.com/en/help/main/10.1/index.html#//00570000007t000000

I must be missing something.  I can view the map service that supports the geoprocessing service and see the features labeled:

[ATTACH=CONFIG]19591[/ATTACH]

I can navigate to the rest services and I see that the �??Has Labels�?� property is set to true. However, the result of the geoprocessing service does not display the labels:

[ATTACH=CONFIG]19592[/ATTACH]

When I navigate to the rest end point for the �??job result service�?�. I can see that the layers �??Has Labels�?� property is set to false.

Has anybody had any experience with this that might be able to point me in the correct direction? Am I miss interpreting what the documentation means when it suggests that �??Labels�?? are returned?

Regards

Sam
3 Replies
AlessandroValra
Occasional Contributor III

Same problem also in 10.3.1.

Ok for Symbology but "has Labels" property in Map Service Layer i set to False (but visible in MXD).

Thanks for any suggest...

TillSchmid
New Contributor II

Same problem here. Is there still no solution?

Anybody has an idea how to include labels in the result map of a geoprocessing service?

0 Kudos
TillSchmid
New Contributor II

In my case the problem could be solved as follows:

The uploaded python script contained «MakeQueryLayer_management» (https://pro.arcgis.com/de/pro-app/tool-reference/data-management/make-query-layer.htm).

In order to display labels on the resulting mapservice, the "QueryLayer" had to be saved as a feature class first («FeatureClassToFeatureClass_conversion»; http://desktop.arcgis.com/de/arcmap/10.3/tools/conversion-toolbox/feature-class-to-feature-class.htm).

0 Kudos