Error with Buffering FGDB polygon feature class

749
1
Jump to solution
03-29-2012 12:11 PM
MathewCoyle
Frequent Contributor
Has anyone run into this issue? I have a script that takes a bunch of points in a FGDB, creates a line with them, buffers the line then does some more analysis and outputs a polygon to a FGDB. At the last stage where I want to do a negative buffer on the polygon I've created, I get an error. I try opening the feature class in ArcMap/Catalog and I can't do a buffer positive or negative. I can run other GP tools on it, merge, intersect, dissolve etc, but not buffer. I tried running repair geometry on it and it found nothing wrong.

Here is the interesting part. If I change the buffer output from a FGDB feature class to a shapefile it works fine. If I export the feature class from FGDB to a shapefile, then run the buffer with the output as a FGDB it works fine. I have reached the end of my troubleshooting abilities. Any ideas?

Here is the error I get.
ERROR 999999: Error executing function. cannot buffer a geometry by a distance of zero units Failed to execute (Buffer).
0 Kudos
1 Solution

Accepted Solutions
MathewCoyle
Frequent Contributor
After two reboots it works, exactly as I executed it before and got an error. Ghost in the machine I guess.

View solution in original post

0 Kudos
1 Reply
MathewCoyle
Frequent Contributor
After two reboots it works, exactly as I executed it before and got an error. Ghost in the machine I guess.

View solution in original post

0 Kudos