tool is invalid

202
2
07-10-2018 06:19 AM
Labels (1)
Occasional Contributor

Guys, I do have a Python toolbox developed under ArcGIS 10.6. This is used in ArcGIS Desktop 10.3.1 and it works without any issues. Also the publishing on ArcGIS Server 10.3.1 works without any issues.

When I open the toolbox on the server in another environment I see the GUI and can select start. Yet after the start it terminates with the message "tool is invalid".

It works perfectly on my ArcGIS Server 10.3.1 single machine deployment but fails with the described error in the other environment.

The python version is the same on both servers.

 

I've seen this thread, yet the answers were not quite sufficient.

The tool structure is as follows:

Any ideas?

Reply
0 Kudos
2 Replies
Occasional Contributor

I just saw recently, that my code contained a nice little snippet in the updateMessages function, which is "invalid" from a Python persepctive:

parameters[8].setWarningMessage (
"Original value was " + str(old) + "m. "
"Rounded to " + parameters[8].valueAsText + " as it is a multiple of 1000m.")

Yet the tool was valid....

I will try the changes in the target environment...

Reply
0 Kudos
Occasional Contributor

Unfortunately the changes made to the tool does not led to a valid tool in the target system. Any othe suggestions?

Reply
0 Kudos