WHERE have they gone: Tools for SDE 9.3 and ArcMap 10

08-25-2016 01:58 PM
New Contributor III


I have started a new job that still uses SDE 9.3 and ArcGIS 10.  I am having trouble finding tools that will work on those versions because most links I find reference the now defunct ArcScripts.

Any help?

Tools of interest for this version of ArcGIS are Geodatabase Diagrammer, X-Ray and anything else of help.  Is there a repository of tools/scripts for the older versions of SDE and ArcGIS?

Thanks in advance,

Amy Rose

0 Kudos
6 Replies
New Contributor III


Thanks so much.  The appsforms site looks promising!  I have been to the other sites but couldn't find older versions to download.

Again Thank you,


MVP Esteemed Contributor

Hi Amy,

Please check if the following works with ArcGIS 10.

X-Ray for ArcMap

X-Ray for ArcCatalog

GeoDatabase Diagrammer for 10X

You can further search, browse, and use code, scripts, models, add-ins, widgets, and more using ArcGIS Code Sharing.

Think Location
New Contributor III

Thanks Jayanta,

I tried to install X-Ray but got an error:  

I guess there is a difference between 10.0 and 10.1.

I did install the GeoDatabase Diagrammer, but it gives errors when I run it.  One error says my Visio Trust Center settings are not set correctly.  I changed the Trust Center settings but I still get the error.

It looks like I will be documenting our GIS model the old fashion way!  Luckily, there are plans to upgrade to newer versions of sde and ArcGIS....

Thank you again,


0 Kudos
Esri Notable Contributor

There was a GeoNet thread about this:  https://community.esri.com/thread/56713  Not sure if it will help but a known issue.

New Contributor III

In case anyone else has the issue with GeoDatabase Diagrammer running with errors:

I have ArcCatalog 10.0 and Visio 2013

I changed the Trust Center Macro settings to "Enable all macros" and Trust access to the VBA project object model checked.

This did not stop the errors.

I then went to the File Block settings and uncheked all the boxes.

Then the GeoDatabase Diagrammer started working.

I left Macro settings as I had changed them. 

Hope this is helpful to someone,