st_geometry.dll for PostgrSQL 9.6

2887
3
10-31-2017 01:42 PM
Highlighted
New Contributor

I am running ArcGIS Server 10.4.1 and have installed PostgreSQL 9.6. However, the latest version of st_geometry.dll listed in my installation directory is for PostgreSQL 9.4. Is there a 9.6 version available, or is this an unsupported combination?

Tags (1)
Reply
0 Kudos
3 Replies
Highlighted
MVP Regular Contributor

PostgreSQL 9.6.x is not supported with ArcGIS 10.4.x or even 10.5.x.

PostgreSQL database requirements for ArcGIS 10.4.x—System Requirements | ArcGIS Desktop 

Minimum supported database versions

The following versions of PostgreSQL and PostGIS are supported with ArcGIS. The specific versions listed are the minimum minor version supported and certified for each supported major release of PostgreSQL. Newer minor versions are supported, but are not certified.

PostgreSQL 9.4.5 (64 bit)
--PostGIS 2.2

PostgreSQL 9.3.10 (64 bit)
--PostGIS 2.2

PostgreSQL 9.2.14 (64 bit)
--PostGIS 2.1

Highlighted
Esri Esteemed Contributor

I think you meant PG 9.6.x is not supported by Esri for enterprise geodatabases, yet. 

It still might be possible to access a non-geodatabase instance of 9.6 with PostGIS 2.2 (though I haven't tried). You won't be using SDE.ST_Geometry with PG 9.6 until at least ArcGIS 10.6,  since extension DLLs are locked to a specific PG release (9.3.x, 9.4.x,...), and 9.6 is not supported.

- V

Highlighted
MVP Regular Contributor

Oops, missed mentioning the unsupported version number. Corrected that in the earlier response. Thanks Vince!