sql view error in Pro

115
2
Jump to solution
05-21-2019 09:18 AM
Highlighted
Occasional Contributor

We have a large, statewide dataset (1,088,439 parcel polygons) in SQL, and we can add it to Pro 2.3.2 and open the attribute table just fine.  We also have a view of this dataset in another database (for read-only access by various users), and while it CAN be added to a map where the polygons appear, an error occurs when attempting to open the attribute table:

Failed to open table.

Error:

An invalid row ID encountered.

The explore (id) tool also does not do anything.  I've deleted and recreated the view with the same results.  I can query all of the records fine in SSMS.

Is this possibly a SQL memory issue? :https://support.esri.com/en/technical-article/000012156  We are running sql 2016.

Anyone else have similar issues?  Note that there is no error message in ArcMap 10.5.1, it just opens an empty table, although the identify tool does work.

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Occasional Contributor III
2 Replies
Highlighted
Occasional Contributor III
Highlighted
Occasional Contributor

Biraja,

Thanks, I had found that but had not realized this dataset contains two similar fields, 'OBJECTID_1' and 'OBJECTID'.  In this case OBJECTID_1 is the object identifier and the OBJECTID field is a text field leftover from geoprocessing.  But we're guessing this is the issue.  I have to wait until this evening when users are gone to release locks so I can delete and recreate the view.  (Deleting and recreating the view in SSMS alone doesn't fix it, because it still needs to be re-registered with the gdb in Arc.)

Thanks for the help.

Justin

Reply
0 Kudos