SAP HANA Geodatabase support in ArcGIS 10.5

1620
3
01-21-2017 10:29 AM
Highlighted
New Contributor

Hi folks, I am looking for some consistent and reliable information about to what extent ArcGIS Desktop 10.5 and ArcGIS Server 10.5 support SAP HANA SPS databases.

- Is this full Geodatabase support (versioning, geometric networks, etc..)?

- what version of SAP HANA SPS are supported.

I have found various information but it's not consistent:

http://support.esri.com/technical-article/000012246/

Articile from 5/5/2016: “In 2016, ArcGIS plans to support SAP HANA as an enterprise geodatabase. The target time frame for Esri's ArcGIS support is late Q4 2016. SAP HANA only supports the newer geodatabase model that is currently under development.”  --> I have not seen further communication from Esri on this.

 

http://desktop.arcgis.com/en/system-requirements/latest/database-requirements-sap-hana.htm

States that only SAP HANA SPS9 and SPS10 are supported database versions for ArcGIS 10.5, but "Geodatabase functionality is not supported with SAP HANA".

https://server.arcgis.com/en/insights/latest/use/supported-databases-insights.htm

Insight for ArcGIS (10.5) support SAP HANA SPS 11 and 12

--> So Insight for ArcGIS supports later SPS versions than ArcGIS Desktop and Server 10.5 do? Weird.

 

http://help.sap.com/hana/Whats_New_SAP_HANA_Spatial_en.pdf

finally states that as of SAP HANA SPS12 (revision 120) “The supported for SAP HANA Spatial has been enhanced: ESRI ArcGIS, SAP HANA as Geodatabase”.

--> Sound promising. Only place I found that states SAP HANA Geodatabase. This seems to contradict the information on Esri's website (see 2nd link above)

Has anyone actually worked already with ArcGIS 10.4 or 10.5 and SAP HANA databases? Does the above make sense and what is your experience as to what  degree SAP HANA SPS is actually supported?

Thanks,

Joep

Reply
0 Kudos
3 Replies
Highlighted
MVP Esteemed Contributor

I have not used it myself, so I can not comment from personal experience. I would suggest using the info Moving Content‌ to move this thread to the Geodatabase‌ space or other similar area other than just developers.

It does look like you have read thru many of the docs that I would have recommended. If you don't get the specific answers you need from the forums, it may take a call to tech support, but I did notice this:

However, only ArcGIS Pro will support SAP HANA as an enterprise geodatabase, and not ArcGIS for Desktop. For ArcGIS for Desktop, the current support for SAP HANA continues to include creating and viewing query layers. Refer to the following SAP HANA blog post for more details.

•ESRI Query Layer integration with SAP HANA

Note:
According to the Supported Environment Policy, an environment is supported when the environment meets or exceeds the base build environment and is known to not fail. Environments that are known to not work are usually documented on the product support page as soon as information is available.

Highlighted
MVP Regular Contributor

Disclaimer: Have not worked with SAP Hana.

It is somewhat apparent from the all the links I read that 

Geodatabase functionality is not supported with SAP HANA

SAP HANA database requirements for ArcGIS Pro 1.4—Help | ArcGIS Desktop 

SAP HANA database requirements for ArcGIS 10.5—Help | ArcGIS Desktop 

If the Geodatabase functionalities would have been available, those links should reflect that.

From this link: Supported databases—Insights web help Use tab | ArcGIS Enterprise  it becomes clear that even Insight doesn't support Enterprise geodatabase

Currently, Insights for ArcGIS does not allow you to create a connection to a relational database that has an enterprise geodatabase defined. Similarly, Insights does not work directly with file and personal geodatabases. For geodatabase tables and feature classes to be used in Insights, they must be made available in your portal organization as either hosted or registered feature layers, and then added to your workbook page.

But as Rebecca stated, if you need an official confirmation, you should contact Esri Tech Support to get the latest updates.

Highlighted
New Contributor

An update on this thread July 31 2017:

ArcGIS Desktop/Pro has supported HANA with query layers and feature services since 10.3/1.2 and HANA 1.0 SP9.   This allows users to access and use the OGC simple feature types and functions implemented in HANA, but enterprise (full) geodatabase support is not supported.

 

Enterprise geodatabase support for HANA 2 SPS02 is coming with ArcGIS Pro 2.1 and ArcGIS Enterprise 10.6, now in beta and scheduled for release in December. This release is based on a new services-based data access model and utility network model. Enterprise geodatabase support for HANA is provided for this release and future releases only; prior releases of ArcGIS will not support HANA as enterprise geodatabases.

 

Insights for ArcGIS supports HANA 1.0 SPS 11&12 and HANA 2.0 SPS1.   Note that Insights uses JDBC whereas Desktop/Pro use ODBC so install the proper drivers.