Point Feature Class in Geodatabase Crashing Train SVM tool

04-10-2019 11:47 AM
New Contributor III

Hi All,

I was trying to use a point feature class (~1500 points) from a file geodatabase for the Train Support Vector Machine Classifier tool.  This feature class crashed my python script and my code in the interactive python window.  When I tried using the feature class in the interactive tool from the Toolbox, the tool crashed as soon as I dragged the feature class into the parameter location in the tool window.

I tried Checking/Repairing Geometry of the feature class and Recover File Geodatabase for the full feature class, but still had the same issue.

I exported the point feature class to a shapefile and it is working just fine in my script.

This is very disconcerting because there is no indication that there is anything wrong with the feature class or the geodatabase, so it was very confusing to debug.   It makes me want to steer clear of file geodatabases all together  

Anyone else run into this sort of thing?  Or have any suggestions for debugging/identifying/fixing when there is a problem with a feature class in a file geodatabase.

0 Kudos
0 Replies