one Oracle View treated as query layer, registration in geodatabase fails - all others are fine?

800
4
11-05-2020 10:50 PM
robert_at_work
New Contributor III

Hi,

I have created 4 views in Oracle (11.2) within one user schema geodatabase.

3 of 4 views appear as Feature Classes in ArcCataolog / AcrMap (10.7.1) - when I open their properties they all have got all the tabs you have for feature classes. I was also able to register them with the geodatabase.

Only one causes some issues - the view appears as "Query Layer" in ArcMap/ArcCatalog and registering it with the geodatabase fails with "invalid entity typ" and "error 999999".

All 4 views are very similar - to a base table containing the geometry I add some fields with lookup values.

Any ideas why one view shows up as query layer and cant be registered eiter?

Thank you, Rob

0 Kudos
4 Replies
George_Thompson
Esri Frequent Contributor

There must be a field or something that the registration process does not like. Have you determined what any differences are between the 2 views (one (or 3) that work and one that does not)?

Are you only including a single geometry type in the view that is not working?

I have seen where one specific field will cause an issue.

Register a table or view with the geodatabase—ArcGIS Pro | Documentation 

--- George T.
0 Kudos
robert_at_work
New Contributor III

Hi George Thompson‌,

thank you for your tip regarding reducing the number of columns. I tried the most basic view: 

create or replace view ele_v_trasse2 as
select tr.objectid,
--tr.globalid
tr.shape
from ele_trasse tr;

Same issue as before. ELE_TRASSE is a SDE Feature class. I tried the view with and without GLOBALID.

I exported the feature class with FME and noticed that some geometries fail in FME GeometryValidator. But as this is an SDE feature class I couldnt find a tool to check the geometry within ArcMap. 

Rob

0 Kudos
George_Thompson
Esri Frequent Contributor

You can run the Check / Repair Geometry in a file Geodatabase; Checking and repairing geometries—ArcGIS Pro | Documentation 

Does the feature class work in the client without any issues?

If so, you may need to reach out to technical support on this.

--- George T.
0 Kudos
by Anonymous User
Not applicable

Hi @robert_at_work 

I have encountered the same thing when extracting from an Oracle spatial table and writing it down to a file geodatabase using FME.

An Oracle spatial table supports different geometries and even null geometries so what I do is I use GeometryFilter transformer to make sure I am getting the target features otherwise a file geodatabase writer which is preset to write a specific geometry would fail.

Regards,

Julius

0 Kudos