Mulituser Geodatabase newbie

2053
2
Jump to solution
11-06-2015 06:22 AM
Highlighted
Regular Contributor III

I have been using ArcSDE for a while now but I am just now introducing true multiuser editing.  We have been using a feature service for a while but now I need to start working with versions etc.  I created a version as a test and made some edits in the version, then I ran the reconcile versions tool and checked post.  The changes disappeared from the version and did not show up in Default.  I tried refreshing the map several times but it didn't seem to help.  I thought I had done something incorrectly.  This morning I thought I would check my webmap to see if the features showed up there and sure enough they were there, all of the dummy features I created (since I did it several times).  Is there typically a delay between the reconcile/post and when it appears in the Default?  In normal practice you might not be expecting the edits to show up that quickly but in a test I want to make sure everything is working properly.  On another similar note, I am running 10.3.1 for both Server and Desktop Standard version but the Versioning toolbar doesn't function properly, it is grayed out for reconcile and post, change versions and conflicts.  Any ideas why I can't use the toolbar instead of the tools?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Esteemed Contributor

Hi Josh,

Yes, an edit session needs to be initiated for the reconcile tool to be active on the Versioning toolbar.

From your previous question, there should be no delay.  The reconcile/post should be reflected immediately in your web map.  I would recommend applying a Refresh interval on the layer.

View solution in original post

2 Replies
Highlighted
Regular Contributor III

EDIT:  Suddenly this morning, the buttons are working.  Do I need to reconcile while in an edit session?

0 Kudos
Highlighted
Esri Esteemed Contributor

Hi Josh,

Yes, an edit session needs to be initiated for the reconcile tool to be active on the Versioning toolbar.

From your previous question, there should be no delay.  The reconcile/post should be reflected immediately in your web map.  I would recommend applying a Refresh interval on the layer.

View solution in original post