Select to view content in your preferred language

Losing "structure" of SDE geodatabase

542
3
04-06-2020 07:10 AM
RasheedKhaleel
New Contributor III

We are using ArcGIS Desktop 10.8 using SQL Server 2016 for enterprise geodatabases from legacy SDE. The newer gdb's seem to work ok, but I'm noticing lately that the SDE, with the most critical data, loses its "structure," that is feature datasets, feature classses are replaced with tables ending with _evw. I don't know a whole lot about SQL Server, and less about legacy SDE, but the only way I can currently get data back how it was is to restore the databases and just not compress. 

SDE geodatabase after compression 

Geodatabase lost structure

Newer structure GDB (ignore highlighted connection, it highlights the bottom one no matter what is selected)

Newer GDB

Any advice how to fix this? Thanks in advance

0 Kudos
3 Replies
George_Thompson
Esri Frequent Contributor

The *_evw are just versioned views of some feature classes. Nothing to worry about there.

What is the actual version of the Enterprise Geodatabase with the issues (i.e. 10.2.2, 10.5, 10.6.1)?

--- George T.
0 Kudos
RasheedKhaleel
New Contributor III

I believe it was 10.3 Looking inside, some of the features can still be previewed as geometry, but most seem to exist only as tables. There is a "shape" field, but not length or area. Polygons only have one "shape" field.

0 Kudos
George_Thompson
Esri Frequent Contributor

You may want to reach out to Esri Technical support and work directly with an analyst on this issue.

--- George T.
0 Kudos