Select to view content in your preferred language

HELP: Connected Replica sync fails "No support for this geometry type."

04-29-2016 09:13 AM
New Contributor III

We use SQL Server 2012 and have ArcGIS.

I created a connected one way (Parent to child) replica from database A to database B.

It has been working fine, but the last sync gave me a "no support for this geometry type error".

I looked at the feature classes and didn't find any strange geometry issues.  I compressed, rebuilt indexes and analyzed the database as well.  It still would not work.

I kept the non-working replica and created a new replica (register exisitng data) and the new replica worked; however,

new changes in database A did not sync over (because I am registering exiting data).

What are my options in this scenario?

I would prefer not having to delete the existing data out of database B and then start over.  Database B has data syncing from several other databases.

Any help appreciated,

Amy Rose

3 Replies
New Contributor III

Well, I have figured this out.  User error but with a helpful hint on correcting the issue.

I accidently added a feature class to the replica that did not exist in the child.  The replica sync'd fine until there was actual changes in that feature class.

Instead of re-building the replica (which would have been painful), a GIS colleague recommended deleting the feature class out of the GDB_ITEMS table in SQL, making sure the path is correct.

I did back-up everything before trying this solution.  I hope to ask ESRI at a meeting later this month to see if this is an "OK" practice or not, but it worked for us (so far).

I will try to remember to comment on what ESRI says.

Hope this helps someone,

Amy Rose

by Anonymous User
Not applicable

Hi Amy,

Its not recommended to edit the database tables to remove information about a feature class Information on a feature class in the geodatabase is stored in many different tables in the geodatabase, not just the GDB_Items table.

The better method is to unregister that one feature class from the replica using the ArcMap/Catalog tools. Then you could create a new replica for that one feature class OR after successfully synchronizing the other data in the replica: unregister the replica, copy the new feature class to the child geodatabase, and then re-register the replica with existing data.

To unregister one feature class from the replica, you would use the Replica Manager (see the link below for more information):

  1. Open the Replica Manger
  2. Right click the replica>Properties
  3. Under the description tab, locate the feature class, right click and click "UnRegister from Replica"

A quick tour of replica management—ArcGIS Help | ArcGIS for Desktop

Hope this helps!


Occasional Contributor III

I'm getting this error trying to create a replica. I am creating a replica from a sql server express geodatabase to a file geodatabase stored on the network drive. 

The replica contains several datasets, tables, and feature classes. 

Any advice?

0 Kudos