Select to view content in your preferred language

Geodatabase must be enabled as geodatabase admin user

15927
15
Jump to solution
10-22-2015 01:58 AM
HaniDraidi
Occasional Contributor II

I've connected to an existing Oracle enterprise database, and I am trying to Geo-enable it  by using the "enable enterprise geodatabase" tool. However I get the following error: "Geodatabase must be enabled as geodatabase admin user. Failed to execute (EnableEnterpriseGeodatabase)."

I got confused, because I am connecting to this database as administrator, but I don't know why I am not able to geo-enable it.

Clip_23.jpg

Clip_24.jpg

0 Kudos
15 Replies
AsrujitSengupta
Regular Contributor III

Use the syntax that was used to connect with SYS user.

Provide a screenshot of the "Connection Properties" of NPROP_PTDT.sde connection file.

0 Kudos
by Anonymous User
Not applicable

With the SYS user you should be able to use the "Enable Enterprise Geodatabase". However, you should assign the required package privileges before. Connect to Oracle with SQL*Plus using SYS, and execute the following:

GRANT EXECUTE ON dbms_pipe TO public;
GRANT EXECUTE ON dbms_lock TO public;
GRANT EXECUTE ON dbms_lob TO public;
GRANT EXECUTE ON dbms_utility TO public;
GRANT EXECUTE ON dbms_sql TO public;
GRANT EXECUTE ON utl_raw TO public;

Privileges for geodatabases in Oracle—Help | ArcGIS for Desktop

Please provide a screenshot of the connection properties as Asrujit suggested.

0 Kudos
AsrujitSengupta
Regular Contributor III

No, the SYS user cannot be used to run the Enable Enterprise Geodatabase tool.

This was the main reason, why this thread qas started.

0 Kudos
by Anonymous User
Not applicable

You are right, but the package privileges should be assigned. See the error with the enable tool.

HaniDraidi
Occasional Contributor II

Many Thanks Richard,

I granted all the permessions to the SDE, but now I am facing a warning (in green color) shown below, Does this affect the Geodatabase?

Clip_1222.jpg

0 Kudos
George_Thompson
Esri Frequent Contributor

Hi Hani,

That is just a warning saying that you do not have the ST_Geometry libraries configured for this specific geodatabase.

You need to configure the EXTPROC on the Oracle server: Configure the Oracle extproc to access the geodatabase with SQL—Help | ArcGIS for Desktop

39119 - Check if the Oracle extproc is set up correctly for direct ST_GEOMETRY SQL queries

38043 - Configure ST_GEOMETRY for use in Oracle 11G Release 2 on Windows

This should get that corrected.

-George

--- George T.
0 Kudos