Export Topology Errors and Versioning

99
2
09-25-2018 09:25 AM
Highlighted
MVP Esteemed Contributor

I have a stubborn issue to resolve: working on a versioned enterprise geodatabase I would like to use the Export Topology Errors in a stand alone script.  The topology itself is base upon an intermediate version, once removed from sde.default.  When I traverse my connection to the EGDB in ArcCatalog, I am connected to that intermediate.  However, what I have discovered has me baffled.

When I run the Export Topology Errors as a tool, and drag the database connection that is to the intermediate version, I don't get any errors exported.  When I run the tool as a command from a Python window in ArcCatalog (after verifying what version I'm working with as described in Workspace properties—Help | ArcGIS Desktop ) no errors get exported.  Finally, in a stand alone script, using the connection described here in, no errors are exported.  What is interesting is in the stand alone script, it shows that I'm connected to sde.default.

Given that the topology is based on the intermediate version, it appears to me that Export Topology Errors looks for errors based on sde.default, and there aren't any errors in sde.default.  That's the point: we correct errors first and then reconcile and post to sde.default.

How do I convince Export Topology Errors to give me the errors we know we have in the intermediate version?

Reply
0 Kudos
2 Replies
Highlighted
MVP Frequent Contributor

Hey Joe:

I don't have a specific answer, but want to add that I have had issues with the Export Topology Errors geoprocessing tool in that it only seems to work under very limited conditions.  Specifically, I can get it to work correctly as a standalone tool, but not when chained to other processes like through Modelbuilder (in those cases it does not operate at all). 

I am not sure if it is Enterprise Geodatabase specific, ArcGIS Desktop specific, or otherwise a bug.  So I feel your pain. 

So for your instance, can you line out some background specifics?  Hopefully someone on here will have some insight on what is going awry:

  • ArcGIS Desktop version being used?  Or Pro version?
  • What Enterprise Geodatabase is in use?

Chris Donohue, GISP

Highlighted
MVP Esteemed Contributor

Hey Chris-  I'm using using ArcGIS 10.5.1, the EGDB is 10.1 with a SQL back end. (10.1; didn't that sunset some time ago?)  I think it could be another example of why I don't like Feature Datasets within the EGDB environment; things tend to get a little flakey....

Reply
0 Kudos