Diagnosing replication problems?

1500
3
09-22-2014 06:14 AM
Highlighted
Occasional Contributor II

Hi,

I'm trying to create a 1-way replica into a FileGDB from an Oracle Enterprise SDE and keep hitting rather unspecific error messages. Here are some details:

  • Client: ArcGIS Desktop 10.0 SP5 with QIP on WS 2008 R2 and ArcGIS Desktop 10.2.1 with Update 1 on Windows 8 64 bit.
  • Database: ArcSDE 10.0 SP5 on Oracle 11.2.0.3 on WS 2008 R2, using direct connect.
  • Database contents: 4 feature datasets with some geometric networks, a handful of relationship classes and some object tables, no class extensions. Almost all tables and feature classes are empty, except for one feature class that has around 4 million rows (building footprints, no network involved).
  • I've tried to make sure that all feature classes and tables are versioned, all have global IDs, database connection for replication is database owner.

I'm using python script that basically creates an empty FileGDB and then creates a replica using CreateReplica_management. The script is OK since I've managed to create one or two replicas with it.

Now, the test environment is a bit of a moving target, and frequently, I run into errors. Typical problems include class extensions, non-versioned feature classes, unexpected locks, missing global IDs, geometry problems in network data. I basically know how to locate and fix those issues, my problem is that I don't know which one it is this time, and checking everything is a lot of work. A typical error message looks like this:

arcgisscripting.ExecuteError: ERROR 000582: Error occurred during execution.

Failed to execute (CreateReplica).

It's a bit too early for a ReplicaLog.dat, there is no Build.txt, documentation for 582 basically says: "An error occurred". I had hoped that 10.2.1 would provide  a bit more information on replication problems than 10.0, but if it does, I haven't come across the information. Does anyone have suggestions on where to look for details of what happened?

Thanks, Martin

Reply
0 Kudos
3 Replies
Highlighted
Esri Contributor

Hi Martin,

As suggested in another entry (Create Replica python script gives error 00582 ) to isolate the problem:

+ Try it first on individual datasets.

+ Try using replication workflow within ArcMap, as this shows more detailed errors.

Richard

Highlighted
Occasional Contributor II

Hello

This error occurs during parameters validation. At least one of the parameters is not valid. As this tool has only three "open" parameters I recommend you:

- Add complete path to your connection file and fgdb location.

- Ensure the OS user that runs the process has permissions on the fgdb folder.

- Ensure the name of the replica is correct (and includes the name os the replica owner: OWNER.REPLICA_NAME).

Hole this helps

Jesús de Diego

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi, thanks Richard and Jesús for your answers. I've got things to work now, and here's a couple of things that went wrong:

  • Wrong name for database connections - the standard path ('Database connection/my.sde') depends on the language settings, and I'd had to fiddle with those for another problem, so these were different on different machines.
  • Versioning: One FDS had to be de-versioning for data loading.
  • Lack of 64 bit Oracle client. Admittedly, this produced 000732 rather than 000582, but since I had installed the 64 bit background processing option half a year ago and not done a lot of GP since then (that probably shows ...), I had forgotten about that.
  • File GDB permission, path etc were OK since my script creates a new FileGDB.
  • Replica name was no problem either since I tried to create it, not to access it, but I guess i would have come across that a bit later.

I can't quite agree that 000582 is parameter validation only, though - we've been using replication in various customer projects (not with GP but with ArcObjects), and 000582 tends to come up in all kinds of situations, including data problems with geometric networks etc.

Still, since error reporting from replication is rather unspecific, it seems a good idea to do some explicit parameter validation or sanity checking of inputs - Shaun Weston's ArcGIS Data Toolkit on github looks like a good place to start ...

Thanks again, Martin