Create enterprise geodatabase errors

2087
2
07-15-2016 06:13 AM
Highlighted
New Contributor

When I Create Enterprise Geodatabase using toolbox in ArcCatalog it errors below. also I create database in SQL server then I add geodatabase connection to arccatalog but when I enable enterprise geodatabase it same errors

I use ArcGIS Desktop 10.3.1 and SQL Server 2014.

What is the error?

[Operastion Failed]
See the setup log in the following location for additional error information:

Colud not create geodatabase tables and stored procedures
Failed to execute (EnableEnterpriseGeodatabase)

LOG INFO:

[Thu Jul 14 15:11:09 2016] VERSION table created...
[Thu Jul 14 15:11:09 2016] SPATIAL_REFERENCES table being created...
[Thu Jul 14 15:11:09 2016] SPATIAL_REFERENCES table created...
[Thu Jul 14 15:11:09 2016] GEOMETRY_COLUMNS table being created...
[Thu Jul 14 15:11:09 2016] GEOMETRY_COLUMNS table created...
[Thu Jul 14 15:11:09 2016] LAYERS table being created...
[Thu Jul 14 15:11:09 2016] LAYERS table created...
[Thu Jul 14 15:11:09 2016] METADATA table being created...
[Thu Jul 14 15:11:09 2016] METADATA table created...
[Thu Jul 14 15:11:09 2016] RASTER_COLUMNS table being created...
[Thu Jul 14 15:11:09 2016] RASTER_COLUMNS table created...
[Thu Jul 14 15:11:09 2016] TABLE_REGISTRY table being created...
[Thu Jul 14 15:11:09 2016] TABLE_REGISTRY table created...
[Thu Jul 14 15:11:09 2016] STATES table being created...
[Thu Jul 14 15:11:09 2016] STATES table created...
[Thu Jul 14 15:11:09 2016] VERSIONS table being created...
[Thu Jul 14 15:11:09 2016] VERSIONS table created...
[Thu Jul 14 15:11:09 2016] MVTABLES_MODIFIED table being created...
[Thu Jul 14 15:11:09 2016] MVTABLES_MODIFIED table created...
[Thu Jul 14 15:11:09 2016] STATE_LINEAGES table being created...
[Thu Jul 14 15:11:09 2016] ERROR in creating STATE_LINEAGES table.
Error: -38
[Thu Jul 14 15:11:09 2016] DBMS error code: 0

[Thu Jul 14 15:11:09 2016] SDE schema object install not completed.
[Thu Jul 14 15:11:09 2016] ERROR installing/upgrading ArcSDE, Error = -1

Thanks

Tags (1)
Reply
0 Kudos
2 Replies
Highlighted
Occasional Contributor II

Hi Rustem-

From the error log you provided and the attached screenshot, I would venture to guess you are having issues that stem from the SDE / Geodatabase Administrator creation process. It appears you are leaving the SDE owned schema option unchecked -if that is the case you must be logged into the SQL Server instance as a user who is dbo in the instance (sa?). Might be worth checking login / user mapping in Management Studio. If that is the case, then the geodatabase should be created in the dbo schema in the database.

Also just check to ensure the proper syntax of your instance (EMI/SQL), as well as ensure that the instance is set to allow for mixed mode authentication since you are attempting to connect using the sa administrative login via database authentication.

A quick test for elimination would be to run the create enterprise geodatabase tool, but select the option for "Sde owned schema", and create a SDE user / password to be the test Geodatabase administrator. If the tool completes then you likely have a login / mapping error with the sa user you are attempting to use to create and administer the geodatabase. I hope this helps!

-Rex

Reply
0 Kudos
Highlighted
Occasional Contributor II

Also, if you try to run the Enable Geodatabase Tool- the proper preconditions must be established in the database via SQL Server Management Studio before you can run the tool. In the code example below, an SDE Geodatabse Administrative user (sde) is created and assigned the necessary permissions to administer the geodatabase. The example that follows also creates a database from scratch named (Testtwo)- maybe try running this script with your own names / parameters and see if you have any success running the Enable Enterprise Tool afterwords?  Just replace paths and database / user names if desired:

CREATE DATABASE [Testtwo]

CONTAINMENT = NONE

ON  PRIMARY

( NAME = N'Testtwo', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLSERVER\MSSQL\DATA\Testtwo.mdf' , SIZE = 3072KB , MAXSIZE = UNLIMITED, FILEGROWTH = 1024KB )

LOG ON

( NAME = N'Testtwo_log', FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLSERVER\MSSQL\DATA\Testtwo_log.ldf' , SIZE = 1024KB , MAXSIZE = 2048GB , FILEGROWTH = 10%)

GO

ALTER DATABASE [Testtwo] SET COMPATIBILITY_LEVEL = 120

GO

IF (1 = FULLTEXTSERVICEPROPERTY('IsFullTextInstalled'))

begin

EXEC [Testtwo].[dbo].[sp_fulltext_database] @action = 'enable'

end

GO

ALTER DATABASE [Testtwo] SET ANSI_NULL_DEFAULT OFF

GO

ALTER DATABASE [Testtwo] SET ANSI_NULLS OFF

GO

ALTER DATABASE [Testtwo] SET ANSI_PADDING OFF

GO

ALTER DATABASE [Testtwo] SET ANSI_WARNINGS OFF

GO

ALTER DATABASE [Testtwo] SET ARITHABORT OFF

GO

ALTER DATABASE [Testtwo] SET AUTO_CLOSE OFF

GO

ALTER DATABASE [Testtwo] SET AUTO_SHRINK OFF

GO

ALTER DATABASE [Testtwo] SET AUTO_UPDATE_STATISTICS ON

GO

ALTER DATABASE [Testtwo] SET CURSOR_CLOSE_ON_COMMIT OFF

GO

ALTER DATABASE [Testtwo] SET CURSOR_DEFAULT  GLOBAL

GO

ALTER DATABASE [Testtwo] SET CONCAT_NULL_YIELDS_NULL OFF

GO

ALTER DATABASE [Testtwo] SET NUMERIC_ROUNDABORT OFF

GO

ALTER DATABASE [Testtwo] SET QUOTED_IDENTIFIER OFF

GO

ALTER DATABASE [Testtwo] SET RECURSIVE_TRIGGERS OFF

GO

ALTER DATABASE [Testtwo] SET  DISABLE_BROKER

GO

ALTER DATABASE [Testtwo] SET AUTO_UPDATE_STATISTICS_ASYNC OFF

GO

ALTER DATABASE [Testtwo] SET DATE_CORRELATION_OPTIMIZATION OFF

GO

ALTER DATABASE [Testtwo] SET TRUSTWORTHY OFF

GO

ALTER DATABASE [Testtwo] SET ALLOW_SNAPSHOT_ISOLATION ON

GO

ALTER DATABASE [Testtwo] SET PARAMETERIZATION SIMPLE

GO

ALTER DATABASE [Testtwo] SET READ_COMMITTED_SNAPSHOT ON

GO

ALTER DATABASE [Testtwo] SET HONOR_BROKER_PRIORITY OFF

GO

ALTER DATABASE [Testtwo] SET RECOVERY FULL

GO

ALTER DATABASE [Testtwo] SET  MULTI_USER

GO

ALTER DATABASE [Testtwo] SET PAGE_VERIFY CHECKSUM 

GO

ALTER DATABASE [Testtwo] SET DB_CHAINING OFF

GO

ALTER DATABASE [Testtwo] SET FILESTREAM( NON_TRANSACTED_ACCESS = OFF )

GO

ALTER DATABASE [Testtwo] SET TARGET_RECOVERY_TIME = 0 SECONDS

GO

ALTER DATABASE [Testtwo] SET DELAYED_DURABILITY = DISABLED

GO

ALTER DATABASE [Testtwo] SET  READ_WRITE

GO

USE [Testtwo]

GO

CREATE USER [sde] FOR LOGIN [sde]

GO

USE [Testtwo]

GO

ALTER USER [sde] WITH DEFAULT_SCHEMA=[sde]

GO

USE [Testtwo]

GO

CREATE SCHEMA [sde] AUTHORIZATION [sde]

GO

USE [Testtwo]

GO

ALTER ROLE [db_owner] ADD MEMBER [sde]

GO

grant create function to sde;

grant create procedure to sde;

grant create view to sde;

grant create table to sde;

Reply
0 Kudos