ArcGIS 10.2 client connecting to ArcSDE 10.4 Ms SQL database

455
1
11-28-2016 07:33 AM
Highlighted
Occasional Contributor III

Hello everyone,

 

Are there any limitations when using an ArcGIS 10.2 client pointing to a ArcSDE 10.4 Ms SQL Server Geodatase?

Can a ArcGIS 10.2 client see a ArcGIS 10.4 SDE Ms Sql Geodatabase?

Is there any difference copying layers from a SDE Oracle 10.0 to SDE Ms SQL 10.4 using a client in 10.2 and 10.4?

Any issues running python scripts to copy layers from SDE Oracle 10.0 to SDE Ms SQL 10.4 in a 10.2 client or 10.4 client?

Any known incompatibilities?

Thanks

Reply
0 Kudos
1 Reply
Highlighted
MVP Esteemed Contributor

The Client and geodatabase compatibility documentation indicates it is supported, but it also states:

You do not have to keep your geodatabase and ArcGIS clients at the same release. Just be aware that, when you make a connection between releases, the functionality available to you may be limited.

....

While ArcGIS 10.1 to 10.3.x clients can open, query, edit, and save data in newer release geodatabases, they cannot open datasets that participate in newer functionality and will encounter the following error message when trying to open one of these datasets:

The version of the Geodatabase client is incompatible with the dataset and cannot open it.

The aforementioned documentation page also has links specific to each DBMS when working in mixed-release environment.

Unfortunately, I haven't found a page that brings together all of the various functionality that won't work when making mixed connections.  I would start by reading the "What's New" documentation for each release since 10.2 to see what new geodatabase functionality has been introduced and won't be available from older clients.