network analysis in arcmap

361
8
01-30-2019 09:30 PM
YELETIRAMA_SIDHARDHA
New Contributor

can anyone please help me to sort some problems in network analysis regarding the data

Reply
0 Kudos
8 Replies
JaySandhu
Esri Regular Contributor

What kind of problem are you running into?

Jay Sandhu

Reply
0 Kudos
YELETIRAMA_SIDHARDHA
New Contributor

while doing network analysis i.e (creating the modal for route analysis) using the road network of dehradun city it is just showing this without any description 

Reply
0 Kudos
JaySandhu
Esri Regular Contributor

Your screen shot does not show the entire error message. And it is not clear what your model is doing. So it is not possible to say what is going on.

There are many reasons a route may not find a path. For example the network dataset is not built or fully connected. There could be restrictions that cause no path to be found. The locations may not have snapped to the network due to search tolerances, etc.

Are you able to solve a route through the UI without using the model?

Jay Sandhu

Reply
0 Kudos
YELETIRAMA_SIDHARDHA
New Contributor

Sir, I'm working on modelling of route analysis of dehradun city (actually in network analysis tutorial of arcmap it is on Ex06 there in the tutorial they took stores as parameters but in  my case as i am unable to find that data so I used institutions as parameters that I obtained through digitization) and that is the total error that is showing after creating the modal. As I am struck here can you please suggest me anything.

Reply
0 Kudos
JaySandhu
Esri Regular Contributor

I am trying to help you. You need to show the error that you are getting in the model. The screen shot you included says:

failure.

No Solution found.

Failed to execute.

WHAT does it say above the "failure"?

Also, are you able to use the NA toolbar to click two stops on the Dherarun data and solve for a path? Does that work? IF it does not solve a path through the NA toolbar then the mode will not work either.

Can you show a screen shot where we can see what locations you are passing in to the model?

Jay Sandhu

Reply
0 Kudos
YELETIRAMA_SIDHARDHA
New Contributor

sir, this is the complete error window that it is showing please tell me what to do now

Reply
0 Kudos
JaySandhu
Esri Regular Contributor

Now that I can see the actual error messages, it is saying that your locations are falling on edges that cannot be reached, most likely because they are restricted. So you need to see check the settings of your network why those edges are restricted. Besides that, you can move the stops to non-restricted edges. You can do this by:

1. Open the route analysis layer property page.

2. Click on the Network Locations tab and then at the bottom left, check on the "Exclude restricted portions of the network" as follows:

3. Click Apply

4. Then in the NA Window, right-click on the Stops and choose Recalculated Location Fields and pick ALL (as shown below)

This will "move" the stops to other close by edges that are not restricted and solve the route again.

In the MODEL, you can check on this property in the ADD LOCATIONS tool as follows:

Hopefully now the route will solve.

Jay Sandhu

YELETIRAMA_SIDHARDHA
New Contributor

Thank you for the help sir, I'll do and will let you know the result.

Reply
0 Kudos