version manager won't open

2501
3
10-08-2013 08:11 AM
KarenWitsell
New Contributor II
Version manager won't open in ArcGIS 10.1. The change version button on the toolbar is not working either but other componets of the toolbar are working. Why is this? How can I get them to work?

I have an ArcSDE database connection with write/edit priviledges and I have a installed SP1. When I select the version manager, nothing happens. When I select the change version I get the following error message:  Error loading versions. [An item with the same key has already been added.]. This appears twice and then the change version window opens but it is not operational and nothing is loaded. Also, when i try to change the version on the table of contents view same thing happens.

I've been searching for information about this and have had no luck. I've had my database administrator reissue edit rights, this has not changed anything. 

Does anyone have some thoughts on the above scenerio? Any help is appreiciated.

thanks,
Karen
0 Kudos
3 Replies
RussellBrennan
Esri Contributor
Hi Karen,

This seems like some sort of installation issue. I would suggest contacting Technical Support directly to go through troubleshooting steps with them.
0 Kudos
DomingoLLagostera
New Contributor
Hi, I am having the same issue. We are using 64bit Windows 7 operating system with ArcEditor 10.1 and Enterprise ArcSDE. This problem is inconsistant. On a machine, it will work for the same user one day and the next day, the version manager window will not show up. We don't get get an error or anything - nothing happens.

I tried shutting down the PC today, started it back up, clicked on the Adminstration from ArcCatalog, then the administer geodatabase and it started working but only after the shutdown. I did the same shutdown on another machine in here and still no response. It is so inconsistant it's difficult to track down the issue. We have another user that was using the version manager just fine a couple of days ago - he tried it today on the same computer and no response, no error, nothing. I asked him to try the reboot but he has not had a chance to do that yet.

I am still trying to track down this problem but if you have an answer for me, please let me know. It's very odd to see this and not even get an error, ArcMap just keeps right on working as if you didn't even press the version manager button.

Thanks,
0 Kudos
DomingoLLagostera
New Contributor
Hi. OK, we figured it out. In our case the error was caused by a third party application (XTools Pro 10.1). After I uninstalled it, the Version manager tool started working again. I have sent an email to their support team requesting informtaion on how to fix the problem or for a patch to XTools Pro 10.1.
0 Kudos