Unable to assign XML schema to output format

05-24-2012 06:34 AM
New Contributor
We are trying to convert data from a File Geodatabase into a GML document that adheres to a GML Application Schema (based on the OGC GML standard release 3.1.1).

Weâ??ve created a Spatial ETL Tool that uses a File Geodatabase as the source, and GML as the destination, but cannot find a location to specify our GML schema. Weâ??ve tried manually mapping elements inside FME as well, but according to this page, to do so requires using the XMLTemplater transformer, and when I try to run the translation after defining one, I get this error message:
This FME edition does not recognize the `XQueryFactory' factory. Please ensure that the current platform supports this factory, the factory name is spelled correctly, and that you have installed all required plug-ins

Weâ??ve also tried (and I think this is our preferred option, if we can avoid having to essentially redefine the schema in FME) creating a destination format based on XML or GML, starting from the writer gallery, but it seems to think weâ??re trying to create a source format (see image below). There is a place here to specify an XML schema if we choose GML as the type, so it seems like this could be the right track, if only we could create a writer instead of a reader.

0 Kudos
0 Replies