Turn off default stretch for opening raster images?

3292
4
06-17-2013 05:47 AM
Highlighted
by Anonymous User
Not applicable
Original User: hitch24

Hi there

I just opened a GIS project, which was created with V9.3. Nothing wrong with that so far 😉 but when I add some additional orthophotos, the "colour" of the images are totally different from the existing ones (see attachments).
I've noticed, when I open a new orthophoto in GIS 10.1 there is a stretch type added to the image (percent clip) and also a gamma stretch is added.
This is a bit annoying, when I have to add a few hundreds of new images where I have to turn off the stretch type manually so all images have the same "colour"
Is there a way to turn off this stretch permanently?

thanks

sincerely
Chris
[ATTACH=CONFIG]25300[/ATTACH]
[ATTACH=CONFIG]25301[/ATTACH]
Reply
0 Kudos
4 Replies
Highlighted
Occasional Contributor
Go to 'ArcMap options' in the 'Customize' drop down menu.

Select the 'Raster' tab then 'Raster Layer'.

Uncheck 'Enable Custom Rendering Defaults'.
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: jbswain

Once the custom options are enabled, you can then choose to switch the stretch to 'None' or any other options you prefer.
Reply
0 Kudos
Highlighted
New Contributor II
Hi Everyone, We are having this same issue.

When I load my raster dataset (which is in SDE) the Stretch and apply gamma stretch defaults to being on.
My "Enable Custom Rendering Defaults" option (as suggested in the above thread) is not checked on. I know I can enable this and set it to "none" but I would have to do this to every PC in our corporation that will be using the images.

Why are the images automatically applying a stretch?  I do not have statistics calcuated.

Is the default option saved somewhere in the dataset itself?

Any help would be appreciated !
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: plefaive

ArcMap uses the statistics calculated for a raster dataset to apply a default stretch when rendering. When statistics are not calculated for a raster dataset, ArcMap will estimate statistics on the fly for rendering which is why your imagery is being stretched despite having no statistics.

A raster dataset property that you may or may not know about is the 'Data Source Type' setting which controls the symbology applied when the raster dataset is rendered. This setting can be found in the raster dataset properties window, there are four options to choose from: GENERIC, ELEVATION, THEMATIC or PROCESSED. By setting the raster to the PROCESSED data type, ArcMap will assume that the data has already been enhanced, therefore no stretch will be applied when displaying the raster.

In your case (if this option works), you would only have to change this property setting in the raster dataset in SDE. Hope this helps!

Paul
GIS Analyst, Esri Canada