Table export limited to 2000 rows?

1881
1
11-03-2014 06:23 PM
Highlighted
New Contributor

I have an odd problem that seems to be new for my system. I am using an online group as a source for my Desktop data and a Surface Pro 3 to run 10.2.2.

 

When I attempt to export a table using the Desktop environment I am (or appear to be) limited to a total of 2000 rows in the table. The actual table is 2987 rows in length. I have never experienced this issue before. Desktop appears to delete specific rows in a random order (they represent a scattered showing on the over all map). The missing rows are always the same but appear to be random on the overall map.

 

The overall map shows all 2987 items but the table eliminates a large portion of them. If I open the table and "select all" a large number of the items do not appear to be selected yet there is no error in what appears on the map (repetitive but I thought I would follow the process).

 

I have tried to restart my system. I removed 10.3 and replaced 10.2.2 thinking that was the problem. I have look over the table options thinking I might find something in there. I have exported the entire layer thinking that it was a specific table export issue with no luck. I have had luck exporting the table by selecting a large grouping and exporting them en mass but have not tried the entire layer.

 

Any help in helping to repair the issue would be appreciated,

 

Scott

Reply
0 Kudos
1 Reply
Highlighted
Esri Regular Contributor

Scott,

It sounds like you are hitting a limit of the service.  It will only give 2000 records in one request.

Are you using a feature service?

If you are and you own it or if you don't own it and it is allowed, you can use ArcGIS online to export the data to a File Geodatabase on your computer.  It should export all of the records.

exportfromonline.png

Mark

Reply
0 Kudos