table attachment not supported error

3133
4
10-08-2014 08:03 AM
Highlighted
Regular Contributor

Jello. I am trying to copy some datasets form our enterprise 10.1 gdb to a file gdb or even another sde gdb that I made. and I am getting the following error message when I try to copy the water dataset:

"Failed to paste sde.dbo.Water

Table attachments not supported in this release of the Geodatabase.

The table was not found. [Water_Net_BUILDER]"

Anybody else experience this.  any help would be great. Thanks

Reply
0 Kudos
4 Replies
Highlighted
New Contributor

Erik - did you ever receive an answer to the question above? We're experiencing the same thing.

Thanks - Bert H.

Reply
0 Kudos
Highlighted
Occasional Contributor

All:  Just FYI, I have a script that exported my sde to a fgdb each night and once I began using the attachment tables I started having problems with the export.  I found one attachment that was corrupt, and I assure you it wasn't easy!  I think I just got lucky after working on this for about 6 months.  So, I would say, try to sort your attachment table various ways.  I found the one attachment that was causing my headaches to be extremely large.  ESRI says that shouldn't make a difference but once I removed it, life was back to normal!

Reply
0 Kudos
Highlighted
Regular Contributor

Elbert

This was a while ago. But if I remember correctly, after talking with esri tech support we came to the conclusion that our Water Dataset had a corrupted geometric network. Because when I tried the same process with our sewer dataset everything worked fine. So the solution that we came up with was to:

Export out just your F.C. into a new FGDB. Then create a new FGDB with a new dataset in that one and then import your F.C. from the first FGDB you made into the second one with the new dataset. Then I suppose rebuild your geometric network if you have one. Hope this is what you were looking for.

Reply
0 Kudos
Highlighted
New Contributor

Erik & Patricia,

Thanks for the replies. It looks like we may be having issues with our

geometric network. I will take a look at the attachment tables as well.

Thanks again and I will let you know how things work out.

Bert Hatchell

ATS | GIS Product Specialist II

bert.hatchell@ats.coop

*The Power of *One* Software Solution - OpenOne*

910.210.4100 main | 910.210.4150 fax

Reply
0 Kudos