Start Editing problem

379
4
08-16-2010 05:25 AM
Highlighted
New Contributor
Hi all,

Any budy could help me out to resolve the problem that I am facing while start editing feature class. I am getting error massage " No data source in the map are registered as versioned or you lack privileges to modify data source which are registered as versioned".
  I have checked the privileged. I think there is not any issue with privileges. Please check the attached screen shot for the error massage that i am getting.

SQL> select grantee, privilege from dba_sys_privs where grantee='SWGAS';

GRANTEE                        PRIVILEGE
------------------------------ ----------------------------------------
SWGAS                          CREATE ANY PROCEDURE
SWGAS                          SELECT ANY TABLE
SWGAS                          CREATE TYPE
SWGAS                          CREATE ANY SEQUENCE
SWGAS                          DROP PUBLIC SYNONYM
SWGAS                          DROP ANY INDEX
SWGAS                          CREATE LIBRARY
SWGAS                          CREATE ANY TRIGGER
SWGAS                          DROP ANY SEQUENCE
SWGAS                          UNLIMITED TABLESPACE
SWGAS                          CREATE SESSION

GRANTEE                        PRIVILEGE
------------------------------ ----------------------------------------
SWGAS                          CREATE OPERATOR
SWGAS                          EXECUTE ANY PROCEDURE
SWGAS                          DROP ANY PROCEDURE
SWGAS                          ADMINISTER DATABASE TRIGGER
SWGAS                          ANALYZE ANY
SWGAS                          SELECT ANY SEQUENCE
SWGAS                          CREATE SEQUENCE
SWGAS                          CREATE ANY VIEW
SWGAS                          CREATE VIEW
SWGAS                          CREATE ANY INDEX
SWGAS                          CREATE TABLE

GRANTEE                        PRIVILEGE
------------------------------ ----------------------------------------
SWGAS                          CREATE TRIGGER
SWGAS                          CREATE SYNONYM
SWGAS                          ALTER ANY INDEX
SWGAS                          DROP ANY VIEW
SWGAS                          CREATE PUBLIC SYNONYM
SWGAS                          DROP ANY TABLE
SWGAS                          ALTER ANY TABLE
SWGAS                          CREATE INDEXTYPE
SWGAS                          CREATE PROCEDURE

31 rows selected.


SQL> select grantee, granted_role from dba_role_privs where grantee='SWGAS';

GRANTEE                        GRANTED_ROLE
------------------------------ ------------------------------
SWGAS                          CONNECT
SWGAS                          EXP_FULL_DATABASE
SWGAS                          DBA
SWGAS                          RESOURCE
SWGAS                          IMP_FULL_DATABASE
Reply
0 Kudos
4 Replies
Highlighted
Occasional Contributor II
Have you tried connecting to the database as the owner of the feature class and granting Select/Insert/Update/Delete permissions to the users who will be performing the edits?

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Granting_and_revoking_privileges_on_da...
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: sanjeevkumar10

Have you tried connecting to the database as the owner of the feature class and granting Select/Insert/Update/Delete permissions to the users who will be performing the edits?

http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/Granting_and_revoking_privileges_on_da...


Hi ianwittenmyer,

Thanks for your responce.
I have already tried this but again the output has been same.
Reply
0 Kudos
Highlighted
Esri Esteemed Contributor
What version of Oracle are you using? (A.B.C.D notation)

What version of ArcSDE are you using?  What service pack has been applied?

What version of ArcGIS are you using?  What service pack has been applied?  Is your
license ArcInfo, ArcEditor, or ArcView?

What is the default version for the connection?  Is this version protected?

- V
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: crrose

I am having the same error. I am using Workgroup SDE (SQL Server Express 2008) and ArcGIS 9.3.1 with an ArcInfo license. I was on Service Pack 1 during my checkout and editing last week and just upgraded to Service Pack 2 with the QIP also applied today to see if that would make a difference and it didn't.
Basically, I created a Checkout off of a 2 way replica, down to my computer, and had done some editing last week. This week, I opened my saved map document to continue editing and received the above error when I tried to go into an edit session. One of the datasets in my checkout can be edited and one does not show up as existing, although both are in my checkout and I can preview them in ArcCatalog (and my edits from last week are in there). They are versioned and I created them and have permissions, I checked both of these things out. I have attached a Word Document with screenshots and further explanation.
Reply
0 Kudos