Snapping to itself

117
3
05-22-2014 01:19 PM
Highlighted
New Contributor
This may be a dumb question but it's driving me bananas!  Is there some way to disable the feature self-snapping option when editing? For example, I'm trying to snap the endpoint of line to another line (moving it a very short distance) and the endpoint snaps to itself rather than the edge of the other line unless I zoom in to a ridiculous scale like 1:20. Why is snapping to itself even an option? Is this a snapping tolerance issue?
Tags (2)
Reply
0 Kudos
3 Replies
Highlighted
Frequent Contributor
Rebecca,

It looks like there is no such option, read here.

Tim
Reply
0 Kudos
Highlighted
Regular Contributor III
A simple workaround is to move the endpoint beyond the snapping & sticky move tolerances,  then move it back within the snapping tolerance of the other line.  There is a snapping tolerance issue and a sticky move tolerance issue, (not to mention the feature topology tolerance) which is why zooming in is another solution, because you probably have your tolerances set in pixels.  You could reduce the pixel size of your tolerances to change the snapping behavior at any particular scale.  If you hit the T key you should see the snapping tolerance zone.
Reply
0 Kudos
Highlighted
Regular Contributor II
I know you can temporarily turn off snapping by holding the space bar down. Maybe that would help in some cases.
Reply
0 Kudos