sde.layers and sde.table_registry records but no tables

1234
3
03-14-2012 02:16 PM
deleted-user-0hg8sVY9GHfr
New Contributor
i'm working with 9.1... how is it that i can find records in the sde.layers and sde.table_registry tables with corresponding records in the sde.geometry_columns table but the attribute and geometry tables don't exist? is this due to an unapproved process for deleting a feature class? just dropping the tables and not de-registering with the sde?

what is the correct process for deleting a feature class? i know that if i can do so using ArcCatalog but haven't tried it. would de-registering with ArcToolbox/General/Delete automatically de-register with the gdb, sde and delete the attribute and shape tables?

thanks in advance.
0 Kudos
3 Replies
VinceAngelo
Esri Esteemed Contributor
That's usually a result of bad database hygiene -- Tables registered with ArcSDE should be deleted
with ArcSDE or ArcGIS tools; tables registered with the geodatabase should be deleted only with
ArcGIS.

The best work-around is to create a trivial table via SQL with the same name, then follow correct
removal procedure (you don't generally need to recreate the ArcSDE-managed tables).  I don't
recommend hacking the registry tables (very unsupported unless on the phone with Tech Support,
and 9.1 is so retired that 9.2 will be retired soon, so this isn't an option).

- V
0 Kudos
ChrisRobinson
New Contributor III
I think I may have a similar problem.  I have a table that I can see in ArcCatalog but am unable to delete as it keeps saying there is a missing DBMS table.  When I view the geodatabase in SQL Server Management Studio, the only reference to the table I can see is in the sde.sde_layers table.  I do not see it listed in the sde.table_registry, sde.column_registry or sde.gdb_objectclasses tables.  Also there is no A, D, F, I, or S table that refers to the layer ID from the sde_layers table.  Any idea of how to remove?  Would removing it through SSMS work since it isn't referenced anywhere else? 

ArcSDE 9.3.1
Windows Server 2003
Microsoft SQL Server 2008 R2

Thanks,
Chris
0 Kudos
VinceAngelo
Esri Esteemed Contributor
The best way to clear metadata about dropped tables is to create a nominal table
with the same name ("CREATE TABLE oops (objectid INTEGER NOT NULL)"), then
to delete it with ArcCatalog.  I've worked with ArcSDE since SDBE 1.2.1, and this
is the way I clear metadata after creation scripting has done horribly wrong.

- V
0 Kudos