Review/Rematch Addresses tool Grayed out

1478
5
03-24-2014 04:59 AM
SamanthaEdwards
New Contributor II
I've run the geocoder on a table of addresses and have the results in a shapefile but the review addresses button on the Geocoder toolbar is grayed out. The geocoded file was automatically added to the map. Is this because the output shapefile is not in the same database workspace as the input locator? I am using ArcGIS 10.0, SP5, ArcInfo license.

Thanks,
S
Tags (2)
0 Kudos
5 Replies
SamanthaEdwards
New Contributor II
For anyone wondering, in order for the Rematch tool to work, the output feature class and the Geolocator have to be in the same database.
0 Kudos
Kazi_IshtiakAhmed
New Contributor
For anyone wondering, in order for the Rematch tool to work, the output feature class and the Geolocator have to be in the same database.


Not necessarily..I have all my custom locators in one folder and output feature classes in another. Just to test what you have just said, I just created two databases. One contained a locator I created using a custom style and the other database contained the output feature class. My Review/Rematch was working just fine (using ArcGIS 10.2).

As far as I knew, for the Review/Rematch to be active and working properly, you need to make sure that you have the correct locator is selected from the "Select Address Locator" drop down list (click "Manage Address Locator">Add if it isn't there) and the output feature class is highlighted.

Hope it was helpful.
Cheers
Kazi
0 Kudos
BradNiemand
Esri Regular Contributor
When you geocode a table of addresses, after the operation is complete, a reference to the locator used to do the geocoding is stored as metadata in the geocoded result.  When you right click on the address table in Catalog, "Review/Rematch" should be enabled.  You don't need to have the locator loaded in the locator manager.  The only requirement is that the locator is in the same location that it was when the table was geocoded.

Brad
0 Kudos
SamanthaEdwards
New Contributor II
For me, I had a pre-created geolocater in an sde and the output was in a shapefile. I'm not sure why it wasn't working properly. But when I exported them both into the same database it worked fine.
0 Kudos
JoeBorgione
MVP Esteemed Contributor
My suggestion is you keep your locator(s) out of a geodatabase and in a standalone directory. Especially SDE; way too much overhead to deal with.  I like to maintain the data in SDE (multi editors) and replicate to a file geodatabase: then the locators point there.  After I sync parent to child, I just have to rebuild the locator(s)....

YMMV...
That should just about do it....
0 Kudos