RepairMosaicDatasetPaths_management kind of works

09-20-2014 09:06 AM
New Contributor III

I have a file geodatabase comprised of many Mosaic Datasets.  The Mosaic Datasets, in turn, are comprised of Oracle SDE rasters.

We have a mandate to change the Orace SDE password for the user that I'm using for my Mosaic Datasets.  Of course, doing so will immediately break my Mosaic Datasets and they will produce the checkerboard map.

So I found the RepairMosaicDatasetPaths_management tool and thought that would solve my problems.  But it doesn't seem to be working.

Here's my code:


   arcpy.RepairMosaicDatasetPaths_management("D:/services_mosaicdatasets/md.gdb/US_test","* D:\\is_server_config\\","#")


After I run that command and then open that Mosaic Dataset in Catalog I can see the path has changed to the new path but Preview still shows a checkerboard.  It's as if it's not reading the credentials from the new .sde file.  I've verified the .sde file works by opening it in Catalog.

I've also tried Modify->Repair option for the selected Mosaic Dataset and also Repair Mosaic Dataset Paths tool in ArcToolbox.  They both produce the same result as the RepairMosaicDatasetPaths_management command - path changes but credentials aren't read.


I'm running Arc 10.2.1 on Windows 2003 Service Pack 2.


What am I doing wrong?  Why aren't the credentials getting read from the new .sde file?  Is there a way to force the Mosaic Dataset to read the credentials from the new .sde file?


Thank you.

0 Kudos
0 Replies