Removing Prefix from Address Standardization

160
6
08-05-2011 05:13 AM
Allison_Laforet__Charko
New Contributor III
Does anyone know how to eliminate having a prefix returned when geocoding in the address standardization? In our dataset, we do not have any street prefixes. When I try to geocode the following address 1234 E C Row Ave E ("E C Row" is the street name), it gets standardized like this:
HN: 1234
Prefix: E
Street Name: C Row
Suffix: Ave
Direction: E

How I want it to be standardized is like this:
HN: 1234
Street Name: E C Row
Suffix: Ave
Direction: E

I've read about changing the .xat/.pat file but I do not have access to the geocoder's SDK.

Any help would be greatly appreciated.

Allison Charko
Tags (2)
0 Kudos
6 Replies
StephanieMacuga
New Contributor III
You may have already tried this but I've usually gotten around that issue by ensuring that my table data has the street name, in your case the entire "E C Row", in one field of the table I'm attempting to geocode.  Then when setting up the locator, I leave the Prefix field empty ("none").  Good luck!

Stephanie
0 Kudos
BruceHarold
Esri Regular Contributor
Allison

If you really mean a prefix street type with abbreviation "E" exists in your locator style, then you can edit the .CLS file in the Geocode directory of your ArcGIS install to comment out the line where the street type "T" has the abbreviation "E".

Look for rows that look like this and put a semicolon at the beginning of the line to comment them out (these are guesses at what the types might be):

ELM        E            T
END        E            T
ESP        E            T

Regards
0 Kudos
BettyLing
New Contributor
I have the same problem.....

In ArcGIS 9.3, the standardization is this:

PreDir1:
PreType1:
StreetName1: MOIN
SufType1: ST
SufDir1:
PreDir2: E
PreType2:
StreetName2: KANE S
SufType2: AVE
SufDir2:
Zone: MUNI

In ArcGIS 10, the standardization is this:

PreDir1:
PreType1:
StreetName1: MOIN
SufType1: ST
SufDir1:
PreDir2: E
PreType2:
StreetName2: KANE SOUTH
SufType2: AVE
SufDir2:
Zone: MUNI

Now, this intersection will not geocode. How to change it back to show up like in ArcGIS 9.3?
Some modifying of the a .CLS file?

Thanks!
0 Kudos
BradNiemand
Esri Regular Contributor
At ArcGIS 10, we have a new geocoding engine and a lot of things work differently then at 9.x.  You shouldn't have an issue matching to that intersection just because the address is standardized with "South" as opposed to "S".  Can you give me some more detail?

Brad
0 Kudos
BettyLing
New Contributor
Hi Brad,

Thanks for your reply. Here's what I have done in more details:

Due to our current business needs, users require the address locator template called �??USAddress.lot�?? that was in ArcGIS 9.x

So, I copied that address locator file to C:\Program Files (x86)\ArcGIS\Desktop10.0\Locators so I can use this template when building a new address locator in ArcGIS 10.x

I created a new address locator in ArcGIS 10.x using the �??USAddress.lot�?? template, based on a street data with the following attribute data:

ST_NAME ST_DIR ST_TYPE MUNI    FROM_LEFT TO_LEFT FROM_RIGHT TO_RIGHT PREFIX SUFFIX
KANE S    E           AVE           VA           1             99                0                   100                     E
MOIN                     ST    VA            1             49                0                    50 

In the Address Locator Properties, I entered the following fields as follows:

House From Left: FROM_LEFT
House To Left: TO_LEFT
House From Right: FROM_RIGHT
House To Right: TO_RIGHT
Prefix Direction: PREFIX
Prefix Type:
Street Name: ST_NAME
Street Type: ST_TYPE
Suffix Direction: SUFFIX
Left zone: MUNI
Right Zone: MUNI

Spelling sensitivity: 100
Minimum candidate score: 100
minimum match score: 100

Connectors: & | @ && /

- Unchecked �??Match if candidates tie�?? (because I want to make sure the address is coded to the correct side of the street and I want to do this manually).

Address Locator created and I go into ArcGIS 10 and click the �??Find�?? button, select the �??Locations�?? Tab and enter the following intersection to see if it will geocode:

MOIN ST / E KANE S AVE, VA

�?�And the address cannot be found�?�

When I click on the �??Show Standardization�?? button it shows:

PreDir1:
PreType1:
StreetName1: MOIN
SufType1: ST
SufDir1:
PreDir2: E
PreType2:
StreetName2: KANE SOUTH
SufType2: AVE
SufDir2:
Zone: VA

and previously in ArcGIS 9.x, it shows:

PreDir1:
PreType1:
StreetName1: MOIN
SufType1: ST
SufDir1:
PreDir2: E
PreType2:
StreetName2: KANE S
SufType2: AVE
SufDir2:
Zone: VA
0 Kudos
BruceHarold
Esri Regular Contributor
Hi

This will take some unravelling; as we don't have ArcGIS 9.x installed here I'll need to rely on you to examine your own files.

If you open your USAddress.lot file in Wordpad and scroll down to the line that looks something like this:

IntFileSTN = us_intsc.stn

Open the .stn file in Wordpad and see what the line starting STANDARDIZE has as the argument.

I'll say it has "us_intsc" as the argument.  It may be different on your system.

This means a file named "us_intsc.cls" is the classification file used as the single view of the world of intersection address tokens.
Open the .cls file in Wordpad and look for lines ending in a letter "D".  These are the street direction tokens.
Whichever file you are using will have an entry for East that looks like this (spaces are not important):

EAST E D

This means that any time an East token is found by the parser it always outputs it a a single letter E.

If you edit the line to be like this:

EAST EAST D

Then the word EAST will be output by the parser.

Make this edit and rebuild your locator and see how it goes.

Regards
0 Kudos