Remove Domain Not Working? Field restricted to coded values even when domain shows as empty in all other screens...

03-21-2017 03:06 PM
by Anonymous User
Not applicable

Field in attribute table was assigned a domain somehow during conversion from other datasource.

How this could even have happened is unknown, as the tool used did not have the options or ability to begin influencing domains and assignments of domains. 

We need this field to be editable.

Went to edit it, and it restricts user to list of coded values for a domain that's been assigned. 

Closed ArcMap, removed domain assignment in ArcCatalog, re-opened ArcMap.

Does not show domain assigned in any properties screen for the feature class or the field itself in the attribute table. 

Went to edit it again... Still restricts user to drop down of coded values from domain. 

Tried Remove Domain from Field tool... could not select field, as it does not show as assigned any domain in any other UI screen. 

Tried Using Assign Domain to Field, then Remove Domain from Field. Still doesn't work. 

Tried dropping it into fresh map file. 

Tried on separate computer with fresh map.

All properties screens and domain/fields screens show that the field is no longer assigned any domain except text value, 254 char.

Still, no user can edit the field except within these coded values somehow.

How is this possible? Thanks in advance for any help! 

0 Kudos
3 Replies
MVP Regular Contributor

Check for Subtypes.

In ArcCatalog > R-click on the FC > Properties > Subtypes

MVP Emeritus

some older articles about editing and working with domains and subtypes

Editing attributes with subtypes and attribute domains—Help | ArcGIS for Desktop 

If removing any subtype doesn't work,    try creating a new field and copying the info over and see if that makes a difference.  It might be an issue with the field and that could be a way to test it. (may want to try on a copy of the data)

by Anonymous User
Not applicable

Thank you! We were able to create a new field and copy the info over as a

workaround, but I still have no idea why it would have still been

restricting the values in the old field after removing the domain

assignment, etc.

I did check subtypes, and it did not appear as though any subtypes were

assigning any default domain to the field at all, all of them showed a

blank space in the default domain assignment tables when managing


Very bizarre!

On Wed, Mar 22, 2017 at 10:31 AM, Rebecca Strauch, GISP <>

0 Kudos