“Reconcile version” tool introduces editing error,

3930
6
01-05-2015 04:43 AM
Highlighted
Honored Contributor

“Reconcile version” tool introduces editing error,

I have the versions structure shown in the screenshot below:

Clip_2.jpg

I wanted to reconcile between Basil and Ahmed + Amjad.

Clip_3.jpg

I got the error below”

Error starting editing on version AHMED.ahmed.[Operation only allowed by the owner of the version [AHMED.ahmed]]”

Clip_4.jpg

What might be the issue here?

Thank you

Best

Jamal

Reply
0 Kudos
6 Replies
Highlighted
Esri Esteemed Contributor

Hi Jamal,

What user are you connected to the database as when you are running the Reconcile Versions tool?  Also, what is the 'Access' set to for each version? i.e. Public, Protected, or Private?  You can check this by right-clicking on the database connection > Administration > Administer Database > Versions tab.

Highlighted
Honored Contributor

Many thanks Jake for
the answer,

I have filled the “input database connection” with the owner and then the “reconcile version” tool works
fine.

Clip_15.jpg

Clip_16.jpg

In case the “input database connection” is filled with a user, “reconcile version” tool introduces the editing error below (as shown in the screenshots posted above)

What does this signify for?

The access type of all versions is “protected”

Clip_19.jpg

The owner of the V1 database is jamal

Clip_20.jpg

Reply
0 Kudos
Highlighted
Esri Esteemed Contributor

Unless the user has 'db_owner' privileges (or sysadmin), the user will not be able to reconcile a version they do not own, unless it's Access is set to 'Public'.

Reply
0 Kudos
Highlighted
Honored Contributor

Thank you Jake for the prompt help,

I thought that one can still reconcile\post between versions in level 2 and level 3 (indicated in the screenshot below) regardless the type of access.

Clip_23.jpg

Reply
0 Kudos
Highlighted
New Contributor II

Many Thanks Jake

Reply
0 Kudos
Highlighted
New Contributor II

Many Thanks Jamal..

Reply
0 Kudos