Reclassify Tool does not create all my classes

1882
9
06-21-2016 08:20 AM
Highlighted
New Contributor III

Hi there,

I am trying to reclassify a layer (distance to roads) into 4 classes:

0 - 10 m --> 4

10 - 20 m --> 3

20 - 40 m --> 2

> 40 m --> 1

However, only classes 1 and 4 appear in my output. If I change it to three classes, only classes 1 and 3 appear. I have used the reclassify tool numerous times before and never had this problem. Can anyone help?

PS: I am converting all my distances from meters into decimal degrees for the reclassification, because my map measures everything in degrees. I don't know if that's important. It has never caused issues before.

Thanks so much in advance for any help!

Tags (2)
Reply
0 Kudos
9 Replies
Highlighted
MVP Esteemed Contributor

it is important since 10 meters is going to be an incredibly small number of decimal degrees, so you will get two classes those less than some threshold and those above.  The solution is to fix your display units to be in meters.  Measurements in degrees are pretty useless since the vast majority of people will have no reference point to understand them

Highlighted
New Contributor III

Thanks for the answers! I would very much like to display in meters and not in degrees, but I didn't manage to change it. You don't possibly know how I could do that?

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

If your data are not projected it, or you could set the coordinate system of the data frame.  The former would make sense since you shouldn't have calculated distance to the road when the coordinates were in decimal degrees.  There are options to calculate them in projected coordinates.  The quickest and best solution would be to get the measures in projected units in the first place.  Any other workaround is just that.

Highlighted
New Contributor III

I am not sure, if I follow. It is not a prohected coordinate system, it a geographic one. WGS 1984

Reply
0 Kudos
Highlighted
New Contributor III

*projected

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Carina...

That is my point... if you want units like meters or kilometers, you have to calculate your coordinates in projected units.  So if you file is a geographic on you can

  • use the project tool, and produce a new file in the projection of your choice and recalculate your values
  • keep the file the way it is, but set the data frame's coordinate system to the projection of your choice then recalculate the values in the coordinate system of the data frame, and not the native coordinates.

The second option is a workaround but it will get the job done.  The first option is to always work in projected coordinates if you intend to do any sort of analysis that involves planar geometry.  For mapping, it doesnt matter since you can set the coordinate system to what you want or use any coordinate system for the data since projection on the fly will allow you to play with the 'look' of the data without fundamentally altering its coordinate values.

Highlighted
New Contributor III

Thanks a lot for your patience with me, Dan. That was very helpful! I will try to implement your advice tomorrow.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

let us know if it doesn't work Carina

Reply
0 Kudos
Highlighted
Regular Contributor II

I have two questions.

First, Are you sure that your attribute table has records of roads in the range from 10 to 40 meter?

Second, What is your steps to create reclassify layer?

Reply
0 Kudos