Problem with the output list variable from a clip process.

04-03-2015 09:06 AM
Occasional Contributor


I have the following model set up to use a polygon to clip six datasets from various geodatabases and then save them into a new geodatabase created with the name of the "clip feature" polygon.


The model itself works fine however when I try to tell it to save to the database using inline variables:

(G:\Active_GIS_Data\Sub_Third_Party_Source_Data\DI\DATABASE\ANALYSIS\DI_Analysis_%Value%.gdb\prod_%Value%...the %Value% is replaced by the value in the NAME field from the iterator.) it doesn't save the paths in the output list variable. 

it worked a couple days ago and now whenever I run the model it only saves the first clipped layer into the new database and saves the rest in the default database.


Even if I replace all the entries in the list, the tool still saves only first clipped feature to the new database. When I validate the model it replaces whatever I put into the output list back to default....except...the first row!

I had to move the original source geodatabases from my desktop to a network drive could this have caused this problem? I also tried saving partial paths only...not complete, and it still has the same problem.

I just want to know what happened and how to fix it.



0 Kudos
0 Replies