PostgreSQL (server doen't listen)

04-04-2012 04:52 AM
Occasional Contributor III

I'm having problems when I try to access to the databes in PostgreSQL. In ArcCatalog and in Postgre Program. The server has installed: Windows Server 2008 R2 Standard 64bit PostgreSQL 8.3 PostGIS 1.2.3 for PostgreSQL 8.3 ArcGIS Desktop 9.3 ArcSDE for PostgreSQL. This is the error that a get [ATTACH=CONFIG]13236[/ATTACH]. I try to restart the service  and I got this messege[ATTACH=CONFIG]13237[/ATTACH].

I tried two things, but without result:
1. For PostgreSQL servers starting with version 8.0, this is controlled using the �??listen _address�?� parameter in the postgresql.conf file. Here, you can enter a list of IP addresses where the server should listen on, or simply use �??*�?? to listen on all available IP addresses. RESULT: The configuration is correct
2. Firewall configured correctly for Port 5432 RESULT: The configuration is correct, the firewall is Disable.

I also try this.In the dbinit.sde file. This was empty so I wrote this lines with the host name and the db name:
set PGHOST=[hostname]
set PGPORT=5432
set SDE_DATABASE=<database name>

After that I went to ArcCatalog and pgAdmin III and try to open the Postgre database and I got the same message 'Serverdoesn't listen"
Then I went to command Prompt and I run this command

C:\Program Files <x86>\PostgreSQL\8.3\bin>netstat -p TCP -a

I got the IP from the Active Connections [ATTACH=CONFIG]13238[/ATTACH] And there I couldn't see the IP running host and the connection on Port 5432 that says in the fist error messege.

I run this command, for ping[ATTACH=CONFIG]13239[/ATTACH]
Windows logs:[ATTACH=CONFIG]13240[/ATTACH]

The log files of Postgres say this:
2012-04-03 14:48:17 VET LOG: database system was interrupted while in recovery at 2012-04-03 14:39:01 VET
2012-04-03 14:48:17 VET HINT: This probably means that some data is corrupted and you will have to use the last backup for recovery.
2012-04-03 14:48:17 VET LOG: database system was not properly shut down; automatic recovery in progress
2012-04-03 14:48:17 VET LOG: redo starts at 1D/2D0689F0
2012-04-03 14:48:17 VET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2012-04-03 14:48:17 VET FATAL: the database system is starting up
2012-04-03 14:48:18 VET LOG: could not open file "pg_xlog/000000010000001D00000031" (log file 29, segment 49): No such file or directory
2012-04-03 14:48:18 VET LOG: loaded library "$libdir/plugins/plugin_debugger.dll"
2012-04-03 14:48:18 VET FATAL: the database system is starting up
2012-04-03 14:48:19 VET LOG: startup process (PID 2580) exited with exit code 255
2012-04-03 14:48:19 VET LOG: aborting startup due to startup process failure

Any one has any idea why this is happening


Diego Llamas
0 Kudos
0 Replies