portgreSQL geodatabase connection

1630
2
10-07-2013 03:42 PM
TianBoZhang
New Contributor
I am currently deploying working environment using this tutorial :

http://resources.arcgis.com/en/help/localgovernment/10.1/index.html#/Publishing_the_Community_Planni...

While I successfully created geodatabase with ArcDesktop 10.1 and postgreSQL 9.0.5, I came to the "set the data source for all layers to the new workgroup geodatabase" step.

I copied the layer into geodatabase, and as I checked the postgresql schema, the table is successfully created.
However when I tried to set the data source and pointed to the geodatabase, the error popped up:

One or more layers failed to draw:

Low Density Residential:  Attribute column not found [planning.sde.CitizenPlanningProposal]

For the record. the original data source is the the same one being copied to the geodatabase.
In other words, the data source set to a certain layer, and I copied this source layer into postgresql, and point the data source to the new location in postgresql, the error appears.

I checked the field in the layer's attribute table and the fields being created in geodatabase, they are all the same.

But the error keeps popping up.

Any help would be appreciated.
Thank you.
0 Kudos
2 Replies
TianBoZhang
New Contributor
problem solved:

http://support.esri.com/es/knowledgebase/techarticles/detail/21955

The SQL query is case sensitive and the original query is written in upper case. however after copy to the geodatabase, the field are all in lower case which cannot be identified.
0 Kudos
VinceAngelo
Esri Esteemed Contributor
It's hard to tell what may be wrong, but the first thing you need to do is
stop loading data as the SDE user.  The SDE user should be reserved for
geodatabase maintenance.  Instead, you need to create one or more users
to own the spatial data, then load data into those users' tables.

- V
0 Kudos