no editable layers and can't edit versioned...

11567
10
04-06-2011 12:08 AM
tongkimongki
New Contributor
i got errors "no editable layers and can't edit versioned workspace.check that you have proper permission on the version". The fc is not versioned and i have un-check the version editing....
I log in as the schema owner. And I have followed the guidelines here http://help.arcgis.com/en/arcgisdesktop/10.0/help/index.html#/User_permissions_for_geodatabases_in_P... for managing user permission.

This happens quite often after I use geoprocessing "Append". First time,second time..i run append, the fc can be edited..after a few times, this error comes up
 
I solve this by copying the data into a new fc and edit this new fc. I want to know why i encounter this error.

[Arcgis svr 10, Desktop 10 SP 1, Postgre 8.3.8]
0 Kudos
10 Replies
gisportaladminsTF
New Contributor II
you have to check all your feature classes (also in a dataset) with sdelayer -o describe -l featureclass,shape -i 5151 -u user.

if the I/O is not NORMAL ( in my case LOAD), you have to do sdelayer -o normal_io -l featureclass,shape -i 5151 -u user.

farewell
Toni Rosin
Landkreis Teltow-Fläming
0 Kudos