mosaic to new raster - weird values

5448
3
02-11-2013 03:17 PM
SarahLawrie
New Contributor
I'm using Mosaic to New Raster to merge a number of dem tiles into one raster, but am having problems.

I need to use the merged raster in a specialised software program in linux, so the merged raster needs to cover a rectangle (ie. each pixel in the rectangle needs to have a value), but the dem tiles don't form a nice rectangle.

To fix this, I've created a polygon that covers the gaps and coverted that to a raster (Polygon to Raster). This raster has 0 value, which is what I want for the gaps it's filling.

I've then used Mosaic to New Raster with the dem tiles and the polygon raster, and it works, but the high and low values for the new merged raster are wrong.

The highest value for the dem tiles is 4810 and the lowest value is -95. Instead the values are 65535 and -92.

Any ideas on what's going on here?
Reply
0 Kudos
3 Replies
JenniferMcCall4
Occasional Contributor III
Are you specifying the Pixel Type in the tool?

If you haven't done so already, I would suggest opening the Properties window of your mosaic dataset via ArcCatalog.  Under the General tab, under Raster Information.  Look at the Pixel Depth and Pixel Type.  Try using these values as the input for the Pixel Type in the tool.  I noticed the 16-bit unsigned ranges up to 65,535 so maybe you were choosing that.

If your data is 16-bit unsigned, then it could be that it shows the min and max values for that pixel type in your table of contents in ArcMap.  However, the values in your DEM may not meet the min and max, it's just telling you the range associated with the colour ramp.  Do you have pixels that you can find in your DEM with a value of 65,535?  If it is just showing the min and max values possible (not necessarily the min and max values in your DEM), then you may be able to do a custom classification in your symbology.

Jenn
Reply
0 Kudos
PiyaliKundu
New Contributor III
**EDIT: I figured out what was going on. My original rasters did not come with an attribute table, and the High /Low values listed below were the stretched symbology values. I created attribute tables for each (by right-clicking on the raster > Symbology > Unique Values) and then looked at the actual attribute tables for the raster. Turns out 3897 is the max value of one of the attribute tables. 🙂 Hope this helps someone else out. **

Hey all! Sorry I'm digging up this topic from a year ago. I am running into the same problem of the Mosaic To New Raster generating a new unrecognizable High value. I am trying to combine four DEM rasters to create a new mosaic so I can extract the values to a points shapefile which spans all four rasters. The High and Low values for all four rasters are as such:

Raster 1: (High) 0, (Low) 0
Raster 2: 2076, 5
Raster 3: 1661, 0
Raster 4: 1774, 8

The new mosaic has a high value of 3897 (the Low is 0)??? I have no idea where this number is coming from!

All four rasters are in 16 bit-signed-integer, which I make sure to specify in the Pixel Type field. I have also tried specifying Spatial reference info and cell size, but it doesn't make a difference. I have tried almost every mosaic operator which applies (first, last, max), and still no luck. 😞 Please help! Thanks!
Reply
0 Kudos
PaulLefaive1
New Contributor
Is the new empty raster dataset that you wish to mosaic your rasters into 16-bit just like your rasters? As well, are all your rasters 16-bit? Something to be aware of that might be causing those strange min/max values...
Reply
0 Kudos