Map Package - General Function Failure

20850
8
01-15-2016 12:28 PM
MikeBly
Occasional Contributor

Hi All,

I am attempting to create an mpk in 10.3.1. I have done several of these, however the current one is just giving me a general function error. Data is SDE base, FGDB, and SHP (folder based). I have removed all raster datasets, shortened the file name of the mxd and output, analyze gives me no returns, ensured that all group layers have no spaces are restricted characters, put in layer descriptions for all.

Cannot get it to package... Any thoughts as to why? Gotta be something simple that I am missing. I have even tried on older version of Desktop, 10.0 and 10.1, same result.

Thanks,.

Mike

8 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Assuming you saw the warning on the main page regarding SDE data

Creating a map package—Help | ArcGIS for Desktop

Without further details, reviewing the steps would be prudent.

ADDENDUM

I am assuming you saw the "More like this" posts to the right of your post? for example

Re: General function failure when trying to create layer package

It becomes somewhat self-referencing and some of the comments are about layer packages but your descriptions of things you tried to exclude that produced errors seems to mirror your.

MikeBly
Occasional Contributor

HI Dan,

Thanks for this, yes I followed the steps outline in the link you sent. I am using SDE data, and checked the box to include the data, not reference. I am using more than just SDE, some FGDB and some folder based shp. Have had no issues with this in the past.

I did read through the "More LIke This" but have not noticed or found anything in there that has got me any closer. I started removing items and adding description, just to try and troubleshoot. When I run the analyze I get no errors, so I am kind of blind as to what the issue may be.

Mike

0 Kudos
forestknutsen1
MVP Regular Contributor

Well I am not sure why the mpk is failing. Would it be possible to use Consolidate Map instead?

Consolidate Map—Help | ArcGIS for Desktop

MikeBly
Occasional Contributor

HI Forest,

Thanks for that suggestion - I was not aware of the Consolidate Map option.

I have tried the three options that  I know of, Share as Map Package, Package Map (Database Management Tools) and then the consolidate map as you mentioned, all of which fail.

Still stumped. The first give me the "General Function Error" the other two give the wonderful ERROR 999999, which is essentially the same thing.

Cheers,

mike

0 Kudos
forestknutsen1
MVP Regular Contributor

Got to love the helpful error messages.

I would try saving the mxd as a copy to help rule it out or create a new one and move the layers over. Then after that I would remove data from each source (SDE, FGDB, SHP) in turn to see if it is a data source problem. But I am just guessing....

KalaKnapp
New Contributor II

I had this problem earlier and just fixed it,

1-Transfer over ALL layers into a new clean GBD.

2-Check geometry and repair where necessary.

3- Change any funny names layers with symbols # / .. etc..

These steps fixed it for me.

Using the File>Share as>Map package.

Barbara_Araujo
New Contributor III

Although this has been posted in 2016, it may interest people to know I had the same problem in March 2022 and this solution worked for me (ArcGIS Pro version 2.9.32379).

0 Kudos
George_ChandeepCorea
New Contributor III

In 10.5 I had to remove the imagery from the mxd and then the mpk processed.

0 Kudos