Make Query Table crashes ArcMap 10.2

965
1
09-23-2016 11:55 AM
Highlighted
New Contributor

I have been using the Make Query Table tool to match a feature class of unique parcel IDs (named PARCELS) to a non-spatial table (named ZONING_CASES) that matches up on parcel ID. PARCELS is the "one", ZONING CASES is the "many".

The goal is to create a feature class of zoning cases based on parcel ID.  I am building feature classes separately for each year back to 2000. So there's a fair amount of repetition.

At first the tool worked fine. I had to strip the quote marks out of the expression in Query Builder, and ignore the error I always get when I verify the expression. (This is a known bug: "error with the expression, general function failure on PARCEL table, too few parameters".)

Then it began crashing. There was a progression. It would crash once, I would re-start ArcMap, reopen the map document, and try again, and the 2nd time it worked. Then it took 3 tries before it worked. Now it works maybe once every 8 tries.

I run ArcMap over a network using Citrix, but I also tested this on a machine that has ArcMap installed locally. It crashed there also. The PARCEL feature class I copy into my GeoDB from our SDE server. The table is imported to the geodB from a csv file. I can find no reason it shouldn't work.

Has anyone seen such a problem before? Is there another way to do it?

Allison  

Reply
0 Kudos
1 Reply
Highlighted
MVP Esteemed Contributor

If this has been reported as a bug and not related to your data or environment, then you can contact tech support or see if it has been reported as such and fixed in subsequent versions.. 

For example http://downloads.esri.com/support/downloads/other_/103-IssuesAddressedList.pdf 

deals with the issues addressed in version 10.3.  I have a link to higher versions in my blog, if you feel inclined to troll through the list of reported and fixed issues ( /blogs/dan_patterson/2016/05/09/the-links )

Reply
0 Kudos