Issue in retrieving Arcmap data using SQL queries in toad.

256
3
02-04-2019 04:11 AM
MuhammadHammad
New Contributor II

Dear all,

I am facing an issue in retrieving Arcmap data using SQL queries in toad.

Arcmap tool gives me a different data of feature class. Whereas, after applying queries in Toad, different data is retrieved of the same feature class. Even though the database connection for Oracle is same.

Where will be the problem and how can I resolve it?

Tags (3)
0 Kudos
3 Replies
FrédéricPRALLY
Esri Contributor

Hi,

Your data cannot be the same depending you read them from ArcMap or directly the table in Toad if you have register as versioned your data. By the way, all updates are stored in the delta table (table A and D) and not in the business table.

To visualize your entire data you must query the view with tableName_EWV instead of table. Using the view terminate with _EWV merge data stored under delta tables and business table.

Hope this is your problem !

Regards,

Fred

0 Kudos
MuhammadHammad
New Contributor II

Thanks for your response.

How can I register the same data, which is shown in ArcMap, to be viewed in Toad using SQL queries?

I didn't find any view in named as "tableName_EWV", in my schema browser using Toad 

0 Kudos
Asrujit_SenGupta
MVP Regular Contributor

Which version of ArcGIS Desktop are you using?

Is the Feature Class versioned? If yes, then there should be a Versioned View created automatically for it. You can check the Feature Class properties in ArcCatalog to confirm this (Under the General tab).

0 Kudos