Input barrier layers

106
6
10-19-2017 02:44 AM
Highlighted
New Contributor

I haved tried to use "Simplify Polygon (Cartography)" on the ArcGis 10.5 with the "Input barrier layers" option, but it seem that does not work properly. I tested it thought points, lines or polygons as barrier layers. 

Maybe it is a bug on that AG version?.

Fran

Tags (1)
Reply
0 Kudos
6 Replies
Highlighted
MVP Esteemed Contributor

image? 

seems wrong? or did you get an error message? or was nothing done?

Highlighted
New Contributor

Nothing done and none message.

Thanks.

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

again....

  • do you have an image of what you are working with
  • can you provide information on the nature of the file?
  • can you show what the dialog settings are for the tool?

perhaps you are setting a parameter that will produce no result.

For example, having a file in decimal degrees and you trying to simplify it by removing values outside the range of the input data.  ie '50' in an unprojected file would mean 50 degrees rather than 50 meters

Highlighted
New Contributor

Dear Dan,

Please, find attached image about the process. 

The layers (polygon to be simplified and line as barrier) are in the same projected dataset. We used the default gdb tolerance (0,001).

We want to block external vertices of the polygon layer, so I used the barrier. But the output shows overshoot and undershoot.

As far as I understand, that should not happen.

Thanks in advance.

Regards.

Fran

Reply
0 Kudos
Highlighted
MVP Esteemed Contributor

Your tolerance may be too strict, and I would also suggest trying one of the other options as well

Simplify Polygon...

and you might want to try it without your barriers first, before adding additional constraints.

Highlighted
New Contributor

Dear Dan,

I am not sure regarding "may be too strict". I need to simplify with 5 m as threshold, I can not see what is the problem.

I have tried line, point and polygon as barrier, but that removing process always change all the vertices (despite of they are on the barrier elements).

I still think it is a bug on the ArcGis. 

Has anyone used it successfully?

Thanks again,

Fran

Reply
0 Kudos