Hatch distortion

2385
6
04-27-2015 01:41 AM
MichalMuszynski
New Contributor II

I got a problem. I created a map and in layout view everything looks fine. When I export it to jpg, bmp or any other format every single hatch (only those with angle 45!) looks distorted. Here are photos to compare:

mpzp--2.jpg << View in LayoutView

MPZP--.jpg << the same part of map in jpg.

I tried to change symbol properties of hatches but It doesn't work.

0 Kudos
6 Replies
DanPatterson_Retired
MVP Esteemed Contributor

Your layout view image has some strange things going on as well...are the data rasters? or contain rasters? since what appears to be roads is quite stepped and jagged in nature, whereas the hatch pattern looks good...unlike in the export.  What version of Arcmap are you using and is your version fully patched?

0 Kudos
MichalMuszynski
New Contributor II

Well, under the vector data there is a raster file (topographic map). The version I use is 10.2.1. Seems to be the newest and fully patched.

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

On a lark...can you remove the raster layer, redo the graphic output and see if it improves...I remember reading something on this site about graphics quality deteriorating when rasters were in the layout/export, but I can't find it.

0 Kudos
MichalMuszynski
New Contributor II

Thank You for clue! I removed the raster but it doesn't work. I tried something different. In symbol properties I've changed type of fill for "Simple Line Symbol" instead the" Cartographic ..." . Distortions are much smaller now, but still visible a little...

0 Kudos
DanPatterson_Retired
MVP Esteemed Contributor

At least you found a workaround...maybe others have a solution...in the interim, hold the product at arms length or further

MichalMuszynski
New Contributor II

I found the solution! In Symbol property editor the line that 'creates' the hatch should be the type of "cartographic line symbol". Then it's need to mark "Square" in Line caps options. That's all.

Anyways thank You for interest and answers !