Geodatabase Compression Error

757
2
06-26-2012 05:52 PM
Highlighted
by Anonymous User
Not applicable
Original User: keets

I have a File Geodatabase made in ArcGIS 10.  This morning, as I was trying to compact the file, I accidentally clicked the Compress File Geodatabase option.  I realized this error and escaped the running process. After this, I cannot open some of the feature classes and tables in my geodatabase.  I�??ve tried uncompressing them but to no avail.  All other files inside the file geodatabase are working except for three files.

Whenever I try to add them as a layer in my map document, they give me this:

[ATTACH=CONFIG]15522[/ATTACH]
[ATTACH=CONFIG]15523[/ATTACH]


When I try to access and edit them in ArcCatalog, I get this error message:

[ATTACH=CONFIG]15524[/ATTACH]

Looking at ArcCatalog, these feature classes and table which give me an error has a �??compressed�?� note on them.  See image below.
[ATTACH=CONFIG]15526[/ATTACH]


Did anyone experience the same thing? How did you solve it?
Reply
0 Kudos
2 Replies
Highlighted
Regular Contributor
Compress and compact make copies of the data. Compress compresses the data into a temp file and then deletes the original and swaps names. The process is similar with Compact. Escaping a running process like this can (like in your case) result in corrupted data. It's better to let the process complete and then uncompress. This may be recoverable. Can you post a listing of the files under the file geodatabase directory. This will let me determine if the data can be repaired.
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: AliceSercul

I also have a compression issue. I compressed a geodatabase file this morning but when I went to uncompress it, although the results indicated uncompression, the feature class within the GDB remained compressed. I then tried to uncompress the feature class by right click - manage - uncompress file geodatabase. I then encoutered 'Background Processing' error to which I sent the error report. I can now no loger open this layer in desktop or repair data source. Can you please help me uncompress??
Reply
0 Kudos