Failure to access the DBMS server

28758
13
01-03-2013 09:26 AM
CynthiaWanschura
New Contributor III
I�??m getting a �??Failure to access the DBMS server�?� error when I try to create an ArcSDE geodatabase in ArcCatalog 10.1.  Someone else had a similar problem:
http://forums.arcgis.com/threads/66442-Cannot-Connect-to-SQL?highlight=Failure+access+DBMS+server

I�??ve tried everything mentioned in that forum but I�??m still having trouble.  Here�??s my setup:

Installed on my 64-bit Windows Server 2008 Server:
- Microsoft SQL Server 2008 R2 (64-bit)
- ArcSDE 10.1 for Microsoft SQL Server
- ArcGIS 10.1 SP1 for Server - Enterprise (Advanced)

Installed on my 64-bit Windows 7 Desktop:
- ArcGIS 10.1 SP1 for Desktop - Advanced (ArcInfo)
- Microsoft SQL Server 2008 Native Client

The installation of ArcGIS Server was a completely clean installation; no version of ArcGIS Server had been on the server prior.  When I recently upgraded a server that had ArcGIS Server 10.0 on it prior, I encountered no trouble.  It makes me think there was a SQL or Windows setting that I changed long ago in 10.0 that carries through but I can�??t think what.  I�??m an administrator both in Windows and in SQL.

I would greatly appreciate help so I can stop banging my head against the wall.  🙂

Thank you!
13 Replies
VinceAngelo
Esri Esteemed Contributor
Did you install the 32-bit native client or the 64?  ArcGIS Desktop is a 32-bit application.

- V
0 Kudos
CynthiaWanschura
New Contributor III
It was already installed so I'm not sure.  How do I find that information?  There's nothing to indicate it as 64-bit in the Programs and Features list in Control Panel.  I am able to access another server running ArcGIS Server 10.1 without an issue, so I assume that the Microsoft SQL Server 2008 Native Client I have on my desktop is compatible with ArcGIS Desktop.  That could be a faulty assumption.

Thank you for responding!
0 Kudos
VinceAngelo
Esri Esteemed Contributor
ArcGIS Server 10.1 is a 64-bit app -- It requires the 64-bit Native client.  The fact that
your old server (where the 32-bit client had been installed for 32-bit AGS 10.0) works
indicates that a missing 32-bit native client could be the issue.

- V
0 Kudos
MarcoBoeringa
MVP Regular Contributor
It was already installed so I'm not sure.  How do I find that information?  There's nothing to indicate it as 64-bit in the Programs and Features list in Control Panel.  I am able to access another server running ArcGIS Server 10.1 without an issue, so I assume that the Microsoft SQL Server 2008 Native Client I have on my desktop is compatible with ArcGIS Desktop.  That could be a faulty assumption.


You may try to use the "SQL Server" ODBC driver instead of the "SQL Server Native Client X.X" too, at least if Microsoft has documented it to be able to connect to your SQL Server version, otherwise it won't be of use. However, I can't find it now, but I think I saw a recent thread where someone reported solving his specific issues regarding driver issues by choosing the non-"Native Client" older driver.

I also recommend you to have a look at this thread by myself, regarding a Windows 7 ODBC driver issue I had. I don't know if it is a general issue and if it is related to your issues, but it will at least help you find out if you run the 32- or 64-bit driver:

http://forums.arcgis.com/threads/70820-BIG-TIP-for-ArcGIS-ODBC-OLEDB-users-on-64-bit-Windows
0 Kudos
SpencerSimpson
New Contributor II
The first thing you should check is Windows Firewall.

By default, Windows Server 2008 enables Windows Firewall, and blocks all incoming connections except those that have a rule allowing something.  

Windows does not create a rule for SQL Server and it does not have a stock rule that you can simply "turn on".

Furthermore, the SQL Server installer (which would be the logical place to have a rule automatically created) does not create a rule for you when you create a SQL Server instance.

In order for remote computers (i.e. anything other than the OS running the SQL Server instance) to accept SQL Server connections you need to add an Incoming traffic rule for the port (tcp port 1433 by default) the instance is running on.  OR turn Windows Firewall off completely.
deleted-user-yFo_UoWEJbkc
New Contributor III

Just want to confirm that this solution is what worked for us. We had our IT turn off the firewall on the server that is hosting our new SQL instance, and vi-oh-lay, the tool ran just fine. We narrowed it down to this as the probable source of the error by attempting to connect to the new SQL instance using Management Studio on a local machine (i.e. not on/within the server itself), and the attempt failed, so that more or less confirmed that "access" to the server was limited. Anyhow, thanks for the tip to help us narrow it down!

0 Kudos
CynthiaWanschura
New Contributor III
ArcGIS Server 10.1 is a 64-bit app -- It requires the 64-bit Native client.  The fact that
your old server (where the 32-bit client had been installed for 32-bit AGS 10.0) works
indicates that a missing 32-bit native client could be the issue.

- V


I need a little clarification.  Am I supposed to install the 32-bit Native Client on my computer or the server?

Thank you!
0 Kudos
VinceAngelo
Esri Esteemed Contributor
32-bit client goes where the 32-bit software is run.  If ArcGIS Desktop is local, then local.

- V
0 Kudos
CynthiaWanschura
New Contributor III
That's what I thought but I'm getting an error that is preventing me from installing the 32-bit Native Client on my computer, "Installation of this product failed because it is not supported on this operating system.  For Information on supported configurations, see the product documentation."  I thought perhaps I was mistaken.  Any recommendations?  Thanks!
0 Kudos