Failed to connect to SDE for Oracle

390
5
Jump to solution
10-08-2013 03:30 AM
Highlighted
by Anonymous User
Not applicable
Original User: shaningesri

In setting up a new CPU and after the installation of some needed softwares, I tried to create a GDB connection to an Oracle DB, but got failed to connect to the specified server.  I am sure that all of the parameters I entered are correct.  What is possible reason for the connection failure?  Thanks if you can share your experience.
[ATTACH=CONFIG]28115[/ATTACH]
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esteemed Contributor
For your instance it should probably be:

sde:oracle11g:DGISDB   not  sdesde:oracle11g:DGISDB

Additionally, you probably only need DCISDB as sde:oracle11g: will be automatically added by ArcCatalog.

Check out this link for information on this matter as it has confused me

http://support.esri.com/en/knowledgebase/techarticles/detail/40576

The smiley faces are a colon followed by an o.  I forget how to switch this off as it does this by default.

View solution in original post

Reply
0 Kudos
5 Replies
Highlighted
Esteemed Contributor
For your instance it should probably be:

sde:oracle11g:DGISDB   not  sdesde:oracle11g:DGISDB

Additionally, you probably only need DCISDB as sde:oracle11g: will be automatically added by ArcCatalog.

Check out this link for information on this matter as it has confused me

http://support.esri.com/en/knowledgebase/techarticles/detail/40576

The smiley faces are a colon followed by an o.  I forget how to switch this off as it does this by default.

View solution in original post

Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: vangelo

The parameters you entered are not correct, which is why the error was generated.
Geodatabase creation prompts for the actual Oracle instance.

In the future, please include the version of ArcGIS you are using, and the actual error
in TEXT within your message, not just a screenshot.

Michael -- The "Disable smilies in text" checkbox is in the Additional Options block.

- V
Reply
0 Kudos
Highlighted
Esteemed Contributor
Vince:

In your post you said that the parameters were not correct, but you did not provide an example of good parameters (That would be very useful for endusers).
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: nidhinkn

When connecting to Oracle, either type the Oracle TNS name in the Instance text box, or provide one of the following Oracle Easy Connect strings:

The name of the Oracle server/Oracle service name or ID
For example, if Oracle is installed on myserver and myosvc is the Oracle service name, type the following:
myserver/myosvc

The name of the Oracle server:Oracle port number/Oracle service name or ID
In this example, Oracle is installed on myserver, is listening on port 60000, and myoservice is the Oracle service name.
myserver:60000/myoservice

The URL of the Oracle server
The URL for the same instance shown in the last example would be:
//myserver:60000/myoservice

The name of the Oracle server (You can use this if the Oracle listener on the server is configured to point to a default instance.)

The IP address of the Oracle server/Oracle service name or ID
For example, if the address of the server is 10:10:10:10, and the Oracle service name is orasvc, type 10:10:10:10/orasvc.
For IPV6 addresses, place brackets around the address. For example: [4000:vu5:0:0:f666:h191:77f5:i2rs]/orasvc

The IP address of the Oracle server:Oracle port number/Oracle service name or ID
In this example, the IP address is 10:20:30:40, port is 59999, and Oracle service is myomy1: 10:20:30:40:59999/myomy1.
An IPV6 address for the same port and service would look like the following: [6543:eo4:0:1:f587:l249:12f9:w3ud]:59999/myomy110:20:30:40:59999/myomy1
Reply
0 Kudos
Highlighted
by Anonymous User
Not applicable
Original User: shaningesri

problem got solved.  In my 1st post I attached an incorrect image.  I did corrected as sde rather than sdesde in the image.  The problem was actually due to my Oracle DB installation.  Thanks to everyone.  I will credit to mvolz47  since he responded first.
Reply
0 Kudos