ERROR: Validate Topology failed.

4364
3
07-30-2013 09:32 AM
JenniferHorsman
New Contributor
I am trying to validate a topology shared between a polygon dataset and a line dataset. There are 3 rules: 1) line features must be covered by the boundary of polygon features, 2) polygon feature boundary must be covered by line features, and 3) line features must not have dangles.

The two datasets I am working on are each the result of a dissolve of other polygon and line datasets which also had shared topology, the rules for which I was able to validate and correct all errors for. But when I try to validate the topology for these dissolved datasets, I get the following error:

"Validate Topology failed.
A failure was detected inside the topology engine. [error id: 257]
Cannot register as versioned on this database."

I do not understand why versioning is even a problem since these datasets are part of a file geodatabase, not an SDE geodatabase. I have tried to run each rule individually, but I get the same error each time.
Tags (2)
0 Kudos
3 Replies
JoeBorgione
MVP Emeritus
Perhaps you could also provide the version of software you are using and service pack level.  I found a something similar with a google search.

You might want to take a look at this.
That should just about do it....
0 Kudos
JenniferHorsman
New Contributor
I am running ArcGIS 10 with SP5 in Windows 7. I think it must have been some kind of out of memory error. I was able to validate the topology just fine when running on a coworker's computer that is supposed to be set up exactly like mine, so I am not sure what the real problem is.
0 Kudos
DianeMcConnaughey
Occasional Contributor
ArcGIS 10.2.  I am having a problem with ArcMap or ArcCatalog crashing when I try to validate topology.   Only one rule - must not overlap, 139 features,2.4 MB.   I have tried zooming in to just a few features, as well as really zooming in to an area where I suspect there is overlap. Have tried network location, C drive, network licenses, checkout licenses, creating new GDBs and new topology. I have also tried a repair geometry, then running the topology check.  I will try to find a another computer - maybe there is something "wrong" with the one I am using.  This also happened in 10.0 SP4, but seemed more random.  Usually validate worked, but sometimes decided to crash consistently for several days
0 Kudos