Error loading versions

643
5
03-03-2017 05:04 AM
Highlighted
New Contributor

Hello,

When I want to change the version in ArcGIS for Desktop I get the error:

(Reason: Invalid at the highest level of the document)

I'm using ArcGIS Desktop 10.2.2 on a Windows 10

ArcGIS Server 10.2.2

name of default version = dbo.DEFAULT

I've read related post on this issue with ArcGIS 10.1 but didn't find a solution that works for me. (there are no special characters in the username, maybe it has something to do with MSXML?)

Does anybody have any idea?

Thanks!

Reply
0 Kudos
5 Replies
Highlighted
MVP Regular Contributor

System Requirements 

to start with, ArcGIS Desktop 10.2.x is not supported on Windows 10.

  • Are you getting this error on different machines as well?
  • Are other users facing this issue if they log into this machine?
  • Do you get the error while changing versions for different geodatabases?
Highlighted
New Contributor

yes we get the same error with other databases and also on windows 7 machines.

Otherwise ArcGIS 10.2.2 works fine on Windows 10. We have over 100 users and we don't have any other issues...

Reply
0 Kudos
Highlighted
MVP Regular Contributor

I'll suggest contacting your local Esri Distributor and discussing with them, so that they can check your environment, databases and troubleshoot in a better way.

Highlighted
MVP Esteemed Contributor

Although I agree you should contact tech support/local distributor, a few other things to check...

  • permissions....could a password have changed for the user(s) recently?
  • authorization...assuming this is ArcSDE for MS SQL?  Could the Sde database have been authorized with a KeyCodes/authorization code that expires? For example, an EDN authorization?
  • any other network related changes?
  • do you have access to SQL manager to view/query the database (not to change)
  • are there any locks on the files?

if you find a resolution, please report back. 

Highlighted
New Contributor
  • permissions: i (we) use the admin pasword
  • Yes it is ArcSDE for MS SQL but not a keycode that expires (licence manager with floating licences)
  • no network changes
  • I can edit/query the DB with SQL manager
  • some files are locked for the users that use the web application but there is no lock for admins when editing with ArcInfo

The consultants that developped our web application have solved the problem on their local machines some time ago but they forgot how they did it...

I think I have to search more in the direction of Microsoft XML Parser en Microsoft XML Core Services...

I will report back if I find the solution.

Reply
0 Kudos