Error: Could not create geodatabase schema. SQL Express 2008R2

2243
5
Jump to solution
01-31-2014 09:43 AM
Highlighted
New Contributor II
I'm trying to enable an enterprise geodatabase on a local SQL Express 2008R2 database using ArcGIS 10.1.  I keep getting the error:

Failed to insert a value to the geodatabase system table.GDB_ItemRelationshipTypes : Error (1)\
See the setup log in...blahblahblah
Could not create geodatabase schema.
Failed to execute...


The error in the log file says:

[timestamp] ERROR Creating Geodatabase tables
, Error = -512
,EXT_Error = 8649
,EXT_ERROR1 = Microsoft SQL Server Native Client 10.0: The query has been canceled because the estimated cost of this query (465) exceeds the configured threshold of 300. Contact the system administrator.
,EXT_ERROR2 =

I'm inclined to just uninstall and reinstall SQL Express 2008R2 and restore existing databases.  SQL was installed on this machine with an older version of ArcGIS...probably 9.3. The machine is still running XP Pro. I've got another machine running Windows 7 Enterprise, ArcGIS 10.1 and clean install of SQL Express 2008R2 and I don't have any issues there. I'm guessing there are some weird legacy compatibility issues?

Any ideas?
Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
MVP Regular Contributor
My gut feeling here is to uninstall/reinstall SQL Express on the XP machine. Experience tells me there is probably some configuration or legacy compatibility issue that will take me longer to troubleshoot than just toasting it and reinstalling.


May be so, but looking at the

,EXT_ERROR1 = Microsoft SQL Server Native Client 10.0: The query has been canceled because the estimated cost of this query (465) exceeds the configured threshold of 300. Contact the system administrator.


extended error, this setting may be applicable and fix your issue:

Configure the query governor cost limit Server Configuration Option (Microsoft Technet)

View solution in original post

5 Replies
Highlighted
MVP Regular Contributor
How are you enabling the database to become a geodatabase?  In other words, what is your workflow and which tool are you using to attempt this?  Here are the 10.1 instructions for enabling a geodatabase within SQL Server Express: 

http://resources.arcgis.com/en/help/main/10.1/index.html#//018t0000000w000000

Since you are using SQL Server Express and since you indicated it is already installed, I believe the process is to create a Database Server connection via ArcCatalog (not the traditional 'Create Database Connection' option like you would for a SQL Server Std or Enterprise database).
Reply
0 Kudos
Highlighted
New Contributor II
I've been through a couple different workflows, all of which work on my Windows 7 machine with a clean install of the most recent rev of SQL Express 2008 R2 but not on the XP machine.

1.) Use GP tool Create Enterprise Geodatabase for my local instance.
2.) Create new database natively in SQL management studio, connect to it in ArcCatalog and then right-click on DB connection and select Enable Geodatabase

My gut feeling here is to uninstall/reinstall SQL Express on the XP machine. Experience tells me there is probably some configuration or legacy compatibility issue that will take me longer to troubleshoot than just toasting it and reinstalling.
Reply
0 Kudos
Highlighted
MVP Regular Contributor
My gut feeling here is to uninstall/reinstall SQL Express on the XP machine. Experience tells me there is probably some configuration or legacy compatibility issue that will take me longer to troubleshoot than just toasting it and reinstalling.


May be so, but looking at the

,EXT_ERROR1 = Microsoft SQL Server Native Client 10.0: The query has been canceled because the estimated cost of this query (465) exceeds the configured threshold of 300. Contact the system administrator.


extended error, this setting may be applicable and fix your issue:

Configure the query governor cost limit Server Configuration Option (Microsoft Technet)

View solution in original post

Highlighted
New Contributor II
@mboeringa2010  Thanks for your insight! Disabling the query governor did the trick. Apparently that had been enabled on this machine some time in the past for unknown reasons.
Reply
0 Kudos
Highlighted
MVP Regular Contributor
@mboeringa2010  Thanks for your insight! Disabling the query governor did the trick. Apparently that had been enabled on this machine some time in the past for unknown reasons.


Good to hear that solved the issue.

You can mark certain posts as the answer to your question / started thread by using the check mark to the right of the post. This will help others find answered questions when they do a search here on the forums.
Reply
0 Kudos